Matomo Website broken

HI, my Matomo web dejboard is broken since some days… I cannot see any update I did

Still I cannot use matomo anymore, but still get the daily report and Matomo itself seems to work fine

Any idea how i can fix this?

Thx

Dan

did you update Matomo?
do you have access to some logs?

Hi @Dan70 !
It seems Matomo itself working fine, just look & feel got disturbed, so if you access the matomo and press right click on it, to go to inspect element and then go to console, you will see errors, please fix or share them. it will help you to fix your issue.

HI, thanks guys!

Any idea where I can find logs in Matomo?
And here is a screenshot from Inspector

Does that make any sense?

I am not aware that I updated it in the last days

Thx a million

Dan

1 Like

is there any adblocker active?

thx @peterbo!!! no, only a blocker for ads in youtube… I deactivated these to test, but the problem persists.

Are you hosted by a third party? (for example infomaniak)
See:

HI, no am hosted on my own server

it all worked great until a few days/2 weeks ago … didnt have time for contacting you for some time

thx
Dan

It looks like your server don’t reply in the good format / encoding / compression… (or the HTTP header is wrong). Does it define well JavaScript MIMEtype? what if you disable file compression?
Are you behind some proxy that could maybe change the HTTP message?

Hii @heurteph-ei … thank you … hmmm… that is beyond me…
but am not behind a proxy

will contact my freelancer admin and see if he has an idea

Thx a million

dan

does this help to see if the MIME is correct?

Hello ! I have the same problem here. Did you find a solution ? Thanks

HI, sorry to hear that…no, not yet :frowning:

1 Like

Can you provide a screenshot of the network log? (in the browser developer tool)

HI @heurteph-ei, thank you…

do you mean this?

Uncaught ReferenceError: $ is not defined
https://piwik.XXX.de/index.php?module=CoreHome&action=index&idSite=1&period=day&date=today:83
index.php:83:9
https://piwik.XXX.de/index.php?module=CoreHome&action=index&idSite=1&period=day&date=today:83
Uncaught ReferenceError: $ is not defined
https://piwik.XXX.de/index.php?module=CoreHome&action=index&idSite=1&period=day&date=today:289
index.php:289:1
https://piwik.XXX.de/index.php?module=CoreHome&action=index&idSite=1&period=day&date=today:289
Uncaught ReferenceError: $ is not defined
https://piwik.XXX.de/index.php?module=CoreHome&action=index&idSite=1&period=day&date=today:318
index.php:318:1
https://piwik.XXX.de/index.php?module=CoreHome&action=index&idSite=1&period=day&date=today:318

?

Laden fehlgeschlagen für das mit der Quelle “https://piwik.XXX.de/index.php?module=Proxy&action=getCoreJs&cb=4212bcb56fda4464401fefa0ef780c03”. index.php:72:1
GEThttps://piwik.XXX.de/index.php?module=Proxy&action=getNonCoreJs&cb=4212bcb56fda4464401fefa0ef780c03
Laden fehlgeschlagen für das mit der Quelle “https://piwik.XXX.de/index.php?module=Proxy&action=getNonCoreJs&cb=4212bcb56fda4464401fefa0ef780c03”.

updated to matomo 4.9.0, still no improvement

No, in the browser developer tool, there is a network tab. In there, some HTTP requests should have some errors…

Hey, sorry, do you mean this?

thx a million
Dan

Yes, is there any HTTP error in this log? (should be red)