WP Matomo + Woocommerce : No woocommerce data shown

We have wp-matomo running on a woocommerce website. This connected to a self managed matomo setup. We’ve installed WooCommerce Matomo Analytics to this set up. The tracking is as below as shown in the plugin config [and included in the pages].

<!-- Matomo -->
<script data-cfasync="false" type="text/javascript">
  var _paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(['addDownloadExtensions', 'pdf|mobi|epub']);
  (function() {
    var u="https://piwik.xxxxx.xxx/xxx/piwik/";
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    _paq.push(['setSiteId', '5']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
<!-- End Matomo Code -->

Somewhere around September 25 we were shown a message in Ecommerce section that it doesn’t have data. Previously, we could see woocommerce data coming and if we select a date range from those times, we could still see this data. Its just that no new data is shown.

If I check the visitor log, I could see orders being placed. But for those orders we don’t see any ecommerce data.

How could I figure out where the problem is? Is there an option to enable debug or something in wp-matomo at Woocommerce end to see if the data is sent? Or is there a way to debug on the matomo end?


You can enable logging in your woocommerce plugin under the Matomo Tab:


You will find the log files in wp-content/uploads/wc-logs/woo-piwik-tracking-yyyy-dd-mm-*.log please let us know if we can help further.

I don’t see such a configuration. Please note that we have wp-matomo. And see the attached screenshots.

I also don’t have such configuration in my Woo settings, and it looks like Matomo is not recording any visitors data on my ecommerce page. Any solution?

I have the same problem. Self managed Matomo and tracking code installation via WP-Matomo plugin. All the settings seems ok but Matomo tracking all the data except the WooCommere data.

I have tried to manually insert Matomo tracking code on the pages but still not working.

What I have to set o check on my Matomo or on my website?


Hi @Accius

Do you have the woocommerce plugin?

Kind regards


hello, I can confirm you that in order to enable Woo statistics you must have the premium plugin installed, as I discussed here. Unless you are a dev and can tweak the code at will. If you succeed, please let me know.

The website has WooCommerce active and sells goods every day. My Matomo has the premium WooCommerce plugin installed and activated.

On my last check, I have seen that on WordPress there isn’t WooCommerce Piwiki Analitycs Plugin. I have installed this plugin now; I hope this solves my problem.