Visitor Log shows "There is no data for this report", but realtime visitor widget shows visitors

I think the symptoms are basically what is here: (and reported many times on the site)

Everything is green in the System Check, except

  • PDO extension (no message, just yellow warning)
  • File integrity File integrity check failed and reported some errors. This is most likely due to a partial or failed upload of some of the Piwik files. You should reupload all the Piwik files in BINARY mode and refresh this page until it shows no error.

File size mismatch: piwik/core/Filesystem.php (expected length: 16057, found: 16062)

  • GD > 2.x + Freetype (graphics) GD > 2.x + Freetype (graphics)
    The sparklines (small graphs) and image graphs (in Piwik Mobile app and Email reports) will not work.
  • Database abilities LOAD DATA INFILE
    Using LOAD DATA INFILE will greatly speed Piwik’s archiving process up. To make it available to Piwik, try updating your PHP & MySQL software and make sure your database user has the FILE privilege.
    If your Piwik server tracks high traffic websites (eg. > 100,000 pages per month), we recommend to try fix this problem.
  • Geolocation Geolocation works, but you are not using one of the recommended providers. If you have to import log files or do something else that requires setting IP addresses, use the PECL GeoIP implementation (recommended) or the PHP GeoIP implementation.

the file integrity warning is expected, because I’ve modified that file according to mysql database name with `+` · Issue #9844 · matomo-org/piwik · GitHub.

The piwik site is also very slow. I don’t yet have access to the server logs, but what should I look for?

Hi there, see: Piwik doesn't track any visits and pages, and shows "There is no data for this report" in all reports. - Analytics Platform - Matomo

Verify the period setting in the calendar in the top panel. Maybe it is set to day without stats, especially if you have just installed Piwik and want stats from previous day when Piwik had not be installed yet.

How to change the default date: