View and superuser config issues on clean install


(Derek Neuts) #1

Hi everyone,

I downloaded Matomo 3.5.1 and installed it on my server (host is Siteground) and while this worked in the past without issues, as of last night with a clean install on a subdomain on a new primary domain, I can’t get Matomo to function. Specific errors range from the following:

  • Personal -> Settings results in: You must be logged in to access this functionality.

  • System -> Users shows user anonymous with no access, and it cannot be changed to View

  • System - > General Settings results in: You can’t access this resource as it requires a ‘superuser’ access.

  • Websites -> Manage results in: You can’t access this resource as it requires view access for at least one website.

I’m running PHP version 7.0.30 and Diagnostic -> System Check results in a clean bill of health, except for Geolocation, which can’t be fixed until these access issues are resolved. My primary login as a superuser is verified through the Manage Super User Access panel, but nothing can be changed or updated (including passwords).

In the past, this was a quick auto install using the default auto-installer via cPanel, but that has also failed now with the same results. Siteground support is not able to resolve it, we’re both equally as puzzled. What took place is that I removed an unwanted, primary domain and replaced it with the addon domain which is my business account. Everything was transferred over and went smoothly, except for this last piece. I’ve attempted using the auto-installer, and I just manually installed Matomo, but the same results. All cache was disabled, Cloudflare disabled for the primary domain (developer mode and purge, just to be sure), and the database was completely remove and reinitiated, so it’s a completely clean install (both times).

@matthieu I could really use your input on this, as well. I’d just like to have it installed properly so I can use it, but I’ve searched through the forums and online in miscellaneous places, and I can’t seem to find anything that may be revealing on this issue. I’ve used this for other clients, but for some reason, it’s not working for my own site now as of last evening.

Thanks for any assistance from anyone on getting this resolved.

Derek


(Derek Neuts) #2

To date, this is still unresolved.