Updateproblem Piwik


#1

Hallo Zusammen,
ich habe Piwik über meinen Hosting-Anbieter aktiviert vor längerer Zeit.
Vor ca. 2 Wochen habe ich es dann wirklich in Betrieb genommen und Einrichtungen vorgenommen.
Leider war es sehr veraltet und ich hatte ein manuelles Update eingespielt, da automatische Updates nicht anklickbar waren.
Nur auf dem falschen Pfad.
Bei dem Versuch, in das Piwik-Portal zu kommen um dies zu ändern, erscheint nun immer die Meldung eines nötigen Updates (s. Anhang).
Wenn ich der Meldung folge durch Drücken des Buttons, passiert nichts mehr (stundenlang).
Ich kann mich weder einloggen, noch sonst irgend eine Funktion in Piwik wahrnehmen.
Was kann ich tun?
Über Hilfe würde ich mich sehr freuen.


#2

Hallo Zusammen,
ich habe noch eine Ergänzung.
Bei dem Versuch ein automatisches Update anzustoßen, habe ich den Fehler erhalten; Die gewünschte Website ist entweder fehlerhaft oder wird gerade gewartet. Als ich im Browser zurückgegangen bin erhielt ich folgende Fehlermeldung:
Fehler: Sie können auf die Ressource nicht zugreifen, da Sie dafür mindestens ‘superuser’ Rechte benötigen.
Danach kam meine Aktualisierungsaufforderung, die dem oberen Anhang entspricht.
Und jetzt kann ich mich auch nicht mehr einloggen, da immer dieses Fenster mit der Aktualisierung erscheint.
Was ist hier nicht korrekt?
Wie kann ich das ändern?
Die Installation ist ganz neu gewesen.
Über Hilfe würde ich mich sehr freuen und danke Euch schon einmal.


(Stefan Giehl) #3

Wenn du Piwik bisher noch nicht verwendet hast ist es evtl einfacher die Installation neu laufen zu lassen.
Lösche dazu einfach die config.ini.php im Config-Verzeichnis und lade Piwik neu.
Bei den Datenbank-Angaben wähle, dass die bestehenden Tabellen nicht weiter verwendet werden sollen (oder lösche Sie vorher)


#4

Hallo SteveG,
danke für Deinen Tipp.
Wenn ich die Installation neu mache (über den Provider), bin ich aber doch wieder auf dem Stand 1.11… und muss auf 2.14… updaten. Wie mache ich das dann am einfachsten oder am besten?
Wenn ich die automatische Version wähle, erscheint ja immer ein Fenster, was vollkommen leer ist und man keinerlei Fortschritt sieht. Es kann doch nicht 5 Stunden oder länger dauern?
Also dann besser über den Dowload der neuesten Version gehen und manuell einspielen?
Oder ist ein ganz anderer Ansatz besser?
Über Hilfe würde ich mich sehr freuen.


#5

Hallo Zusammen,
ich habe noch eine weitere Ergänzung zu meiner Aktualisierungsaufforderung, die erscheint, wenn ich mich einloggen möchte:

"Wenn Sie die Aktualisierung nicht von der Kommandozeile aus ausführen können und auch Piwik die Aktualisierung nicht durchführen kann (wegen Zeitüberschreitungen der Datenbank, des Browser oder sonstigen Fällen), können Sie auch die SQL-Befehle manuell ausführen, um Piwik zu aktualisieren.

› Klicken Sie hier, um die Liste der auszuführenden SQL-Befehle anzuzeigen."
Details s. Anhang

Vielleicht muss gar nicht alles neu gemacht werden.
Aber ich weiss leider nicht, was und wie ich jetzt vorgehen muss, um auf den neuesten Stand zu kommen.

Über Eure Hilfe würde ich mich sehr freuen und danke Euch schon einmal.


#6

Hallo Zusammen,
also ich habe die Installation von Piwik jetzt wieder ganz neu gemacht (über Hoster).
Da hier wieder aktualisiert werden muss, habe ich diesmal die manuelle Version per Download entpackt und per FTP hochgeladen. Ich habe auch auf das Überschreiben geachtet.
Aber leider komme ich jetzt beim nächsten Login-Versuch wieder an meiner alten Stelle an, die ein Update fordert.
Die Informationen mit den Anhängen seht Ihr weiter oben.
So ganz klar ist mir das jetzt aber nicht. Was kann denn hier das Problem sein?
Über Hilfe würde ich mich sehr freuen und danke Euch schon einmal.


(Stefan Giehl) #7

Hast du Zugriff auf das PHP-Error-Log? Falls ja, versuch mal das Update automatisch machen zu lassen, und schau ob im Error-Log ein Fehler auftaucht. Evtl lässt sich darüber nachvollziehen wo das Problem liegt


#8

Hallo SteveG,

danke für den Hinweis.

Also ich habe jetzt folgende Fehlermeldung nach dem Versuch des automatischen Update mehrfach erhalten:

PHP Fatal error: Class ‘Piwik_Plugin’ not found in …plugins/ExampleUI/ExampleUI.php on line 27, referer: http://…
[Wed Jul 29 15:11:42 2015] [error] [client …] File does not exist: …www/robots.txt
usw.

Kannst Du damit vielleicht etwas anfangen und mir sagen, wo der Fehler liegt und was ich tun sollte?

Ich danke schon einaml für Eure Hilfe.


(Stefan Giehl) #9

Lösch mal das Verzeichnis plugins/ExampleUI und schau ob es dann funktioniert, das Plugin wird im Livebetrieb nicht benötigt.


#10

Hallo SteveG,
danke für diesen Tipp.
Ich habe das Verzeichnis gelöscht und das automatische Update von Piwik gestartet.
Leider kam sehr schnell die Meldung (s. Anhang).

Was könnte man sonst noch tun?


(Stefan Giehl) #11

lösch mal das Verzeichnis plugins/UserSettings und überprüfe die Schreibrechte deiner Piwik-Installation. Mir kommt es so vor, als ob der Webserver nicht ausreichend Rechte hat die Dateien zu aktualisieren bzw. zu löschen.


#12

Hallo SteveG,
ich habe es inzwischen geschafft, Piwik korrekt in das Verzeichnis zu bekommen.
Jetzt scheint es zu laufen und ist auch auf dem neuesten Stand.
vielen Dank für Deine Hilfe.


#13

Hallo,
nach dem letzten Update (eigentlich seid den letzten 3) hab ich auch ein Problem, und weis nicht wie ich das beheben soll.
Nach den Updates kommt Piwik einfach nicht mehr wieder.
In der Browserzeile steht
http://xxxx.xxxx.xxx/admin/piwik/index.php?module=CoreUpdater&action=

Und die Seite bleibt weis und leer.
Ich hab dann via Ftp Piwik nochmal überspielt (das hatte bisher eigentlich immer geklappt) aber selbst dann geht er nicht weiter.

Da ich mich mit PHP nicht auskenne, kann ich mir nicht helfen. Ich hab mal nach einer Log oder sowas gesucht, aber ich finde nichts.

Würde es funktionieren, wenn ich das Config-Verzeichniss sichere, und dann alles Lösche, das Update nochmal hoch lade und dann das alte Config-Verzeichnis wieder dazu schreibe ?

mfg und danke
Wolfgang


#14

Hallo,
in meiner verzweiflung habe ich jetzt das Piwik-Verzeichnis auf dem Server via FTP gelöscht, und das neue Piwik aufgespielt.
Den ersten screen bekomme ich noch angezeigt, aber bei der Systemprüfung bleibt der Bildschirm schon weis, und er reagiert nicht mehr. Lässt sich also nichtmal “normal” installieren.
Dann steht er in
…/admin/piwik/index.php?action=systemCheck&trackerStatus=500

mfg
Wolfgang


#15

Hallo Wolfgang V.

exact so sieht es bei mir auch aus, ich bin bei One.com, ob es daran liegt? Denn auch ältere Versionen die ja mal gingen kann man nicht mehr installieren.

Gruß
Dexxaman


#16

Hi Dexxaman ,
ups, ja, da bin ich auch…
Ich hab die 2.13.1 noch als SicherheitsKopie hier gehabt, die hab ich per FTP hoch geschoben. Von meinem Config-Verzeichniss hatte ich im Laufe der Jahre Backups gemacht. Dieses Backup hab ich dann da rein Kopiert, und so war ich wenigstens nicht mehr ganz “Blind”. es lies sich wieder starten. Das was ich brauche, geht noch.

Keine Ahnung was da los ist ??? One.com ? Weis nicht ?? Zufall ?
Falls da noch mehr Leute sein sollten, die bei One.com sind und … wär nett … vielleicht kommen wir ja dahinter ?

mfg
Wolfgang


#17

Hallo an alle,

schließe mich der Problematik an. Habe meinen Webspace auch bei One.com, jedoch lief bisher so ziemlich alles ohne Probleme mit den älteren Versionen. Und ich bin schon ein ganze Weile dabei. Aber ebenso ist bei fast jedem Update “Domain.de - Seite nicht gefunden” in der Adresszeile das letzte was stets übrig bleibt. Bisher war ein Aktualisieren oder Neuaufruf der Piwik Login Seite erfolgreich. Diesmal leider nicht.

Falls jemand einen Tipp hat, bitte posten und nicht wie so häufig “hat sich erledigt…”

Danke

P. s.: Ich würde mich übriges freuen, falls jemand noch ein 2.11 oder so in der Ecke liegen hätte… Danke schon einmal…

edit: die Seite bleibt dabei immer weiß…


(Stefan Giehl) #18

Habt ihr Zugriff auf das PHP-Error-Log? Wenn eine weiße Seite angezeigt wird scheint irgendwo ein Fehler aufzutreten.

Im übrigen gibts all alten Releases von Piwik hier: http://builds.piwik.org/


#19

Hi,
danke für die Downloadliste. Habe es dann mit 2.10.0/11.0/14.0/14.3 versucht. Klappte nicht. Jedoch hatte mir Piwik das erste mal eine Meldung angezeit:
[attachment 2414 piwik-fehler.png]

Danach hatte ich dann die aufgeführte 2.14.1 versucht und leider wieder ohne Erfolg. So langsam macht mich das Ding wahnsinnig…

Diese Art von Problem hatte ich bereits bei einer vorigen Version, jedoch hat die “Rettung” funktioniert. Diese mal mache ich mir ernsthaft Sorgen, dass die Daten ja bloß erhalten bleiben bei Installation. Letztes Backup ist was älter…

Brauche also leider noch Hilfe. Wer noch einen Tipp hat, bitte immer her damit. “Nerver touch a running system…” hätte ich wohl den Updates vorziehen sollen…


#20

Hallo zusammen,

ich habe mich nun nach erfolglosen Reparaturversuchen mit meinem Provider “One.com” in Verbindung gesetzt. Dies ist die Antwort:

“…Bitte beachten Sie, dass Piwik bei One.com nicht unterstützt wird und daher leider nicht verwendet werden kann.
Dieses ist der Fall, da Server Einstellungen in der php.ini Datei verändert werden müssen und dieses leider nicht möglich ist.
Bitte prüfen Sie daher nun einmal die Verwendung eines anderen Programms…”

Tataaaaaa… Mehr muss wohl nicht dazu gesagt werden…