RESOLVED : Release 1.1.1 : not able to login on some of my customers sites


#1

Hi all,
After applying release 1.1.1 on some of my customers sites, I am now not able to login to these statistics sites.
I have read all the posts about the subject and none of the solutions correct the problem…
This morning, on one of these sites, I install the last package (They said in the posts that the last package include all the patches…)
The problem is always alive : When you login nothing happens.

The problem seems to exist only on my infomaniak sites.
Two files are attached to compare the php.ini files (running and not running)
Il hope this help in the resolution.

Regards.


#2

I have got the same problems.
PHP Version 5.2.6
Freebsd 7.0


#3

J’ai le même problème que “jcnconsultant”. Je suis également hébergé chez infomaniak. php 5.2.14
Mais dans mon cas, il s’agit d’une nouvelle installation dans un dossier vierge et avec une base vierge.

Par ailleurs, à la suite de l’upload des fichiers, en FTP, j’ai 3 fichiers en erreur :

Le contrôle d’intégrité a échoué et a rapporté des erreurs. Cela est probablement du à un envoi de fichier partiel ou en échec des fichiers de Piwik. Vous devriez envoyer de nouveau les fichiers de Piwik et rafraichir cette page jusqu’à ce qu’elle n’affiche plus aucune erreur.
Différence de taille de fichier : /home/www/566aa1e5b8381f2eb8aa8b821c41173f/web/piwik/lang/nb.php (longueur attendue: 68939, rencontrée : 67854)
Différence de taille de fichier : /home/www/566aa1e5b8381f2eb8aa8b821c41173f/web/piwik/lang/nn.php (longueur attendue: 60326, rencontrée : 59355)
Différence de taille de fichier : /home/www/566aa1e5b8381f2eb8aa8b821c41173f/web/piwik/lang/th.php (longueur attendue: 149538, rencontrée : 148292)

Je les upload à nouveau et je vérifie le nombre d’octets. Tout est bon mais l’installateur continue de m’indiquer une erreur.

Sur plusieurs upload successifs et complet, j’ai toujours ces 3 mêmes fichiers en erreur au premier upload.

Une idée ?


(Matthieu Aubry) #4

This is a bug for some users in 1.1 please see and post your config details in the bug report: Broken json extension: Login not working in 1.1.1 for some users · Issue #1958 · matomo-org/matomo · GitHub


(vipsoft) #5

By “nothing happens”, do you mean you get a blank screen, or you’re returned to the Login form without any error message?


#6

Hi Vipsoft,
By “nothing happens” I mean : I return to the login form without any error message

Regards


#7

Hi there,

the same issue happen for me (also hosted on infomaniak). I tried to upgrade my previous version or to install a fresh one, but I got he same behavior: after entering my login information, I am bounced back to the login page, even without any error message.

Thanks in advance.


#8

Same error for me:
I return to the login form without any error message when i fill in the correct username and password.
I 'll get a message when the u+p is incorrect.


#9

Any news regarding this problem, cause I have the same today : I try to login and nothing happen, just go back to the login page…


#10

Hello all,

the same problem happen to me (also hosted on Infomaniak).

I’m always returned to the login page, even without any error message.

my parameters:
WEB SERVERS: Apache

PHP Version: 5.2.14:

MySQL Version: Ver 14.12 Distrib 5.0.84, for pc-linux-gnu (i686) using readline 5.1

Thank you in advance.


#11

Hi all,
I have alert Infomaniak today.
They are investigating. I gave them all the information needed (sites working or not, username, passwords…)
I am waiting for an answer.
Regards.


#12

Hi all,
Question for all of the users who have this problem :
Have you had problems with the load of your files via FTP (Filezilla or FTP Expert) ? Interruptions, lockings…
Your answers will be appreciated.

I had them and I am thinking about files corrupted.
Regards


#13

no but troubles during setup “Corrupted languages files”


#14

No problems for me.


#15

Same problem to login with 1.1 and 1.1.1, hosted on Infomaniak with php 5.2.14. I had no problem to upload files via FTP and the files were not corrupted.

The only problem I saw was a error message telling me that I was behind a “reverse proxy” or something like that and that I should set proxy_host_headers[] or proxy_client_headers[] (I don’t remember precisely) in my config.ini.php, which was not writable at that time. This error triggered once at the end of the upgrade from version 1.0 to version 1.1 …

Adding proxy_host_headers[] = HTTP_X_FORWARDED_HOST in config.ini.php doesn’t help


#16

No problems for me.


#17

@jcnconsultant

No problem with FTP.
I use Transmit from my Mac.


(SebNYD) #18

Hello,

Same problem here with Infomaniak, I’m unable to login into Piwik (no error message, I’m just stuck on the login screen).

I’ve contacted Infomaniak support.

For what it’s worth, I had absolutely no issue during Piwik upgrade yesterday (upgrape from 1.0 to 1.1.1).

Regards,

Sebastien


(jOoL) #19

same for me, also present in 1.1b4.

Also by infomaniak
Proxy variables edited without success.

Hope solution comes soon. Reverting to 1.0


#20

Peut-être suite à des demandes, Infomaniak update son php mercredi 12/01 au matin : mise à jour php 5.2.14 vers php 5.2.17 sur certains serveurs (imu218).

php 5.2.14 sur IMU176 (inchangé)
php 5.2.14 sur GMU15 (où je teste : inchangé)