Problems with PHP 5.4.10

A few days ago, I updated my PHP version to 5.4.10 (before 5.4.8 as far as I know). Since then, some widgets and sites don’t load anymore. E.g. the visits by server time, keywords or overview but even pages like Visitors -> Visitor log.

While loading the dashboard, I get the message “Oops… problem during the request, please try again.”, but how can I look for what’s exactly wrong while loading the content?

Would be appreciate to get help! :slight_smile:

Have you tried to delete and re create the widgets?

I removed one, yes, and it’s not possible to readd it to the dashboard anymore. Even the preview doesn’t load in this widgets.

ok can you check your php.ini memory settings perhaps bump it up?

What version of piwik are you using?

I’m using the latest version 1.9.2 of piwik. My memory_limit is 256M, that’s high enough. :wink:

Hi ok, yes should be fine.

Can you tell me what version of python you are using?

Is there any error logs you can find for the server that will help us?

Who is the ISP? Is this a VPS type of server or your own stabd alone? what server config do you have?(i mean OS and linux distro) unless its a windows one.

Python is version 2.6.6 on a Linux Debian Squeeze 64-Bit with PHP sources from DotDeb. It’s a dedicated server, which I administrate by myself. Except of this, I have no other problem, especially with PHP.

Neither the server logs (lighttpd) nor the PHP error logs are logging anything.

The only error, which occurs is the following:
[05-Jan-2013 21:23:24 UTC] PHP Fatal error: Nesting level too deep - recursive dependency? in /var/www/piwik/core/View.php on line 44

However, it doesn’t log everytime I view the piwik stats thus I don’t think that this is the main problem, here.

ok the python i know ideally should be 2.7.3 at least so there is one potential issue.

That error could be a regression (see below), any chance you could try the latest beta to see if that fixes the issue? Maybe do the python update first see if that helps then try the beta?,78070

Generally, I dislike to update to any version, which doesn’t come through the stable update server…

Your link provides a possible solution, which already is implemented, thus I don’t know how it should help me, sorry. :frowning:

i understand though this beta is quite advanced and stable as far as its been beta for longer than most of teh betas i ve seen. Bottom line i respect your decision.

the link was to show perhaps you need to mention to dev team that this regression has potentially taken place.

I would definitely update the python since you updated the php though.

There is a /tmp folder in the piwik folder that might help here if you delete its contents and try to recreate your widgets.

Okay than. I updated to v2.7.3rc2 of Python, cleared the cache but unfortunately, the error still occurs. :frowning:

what browser are you using?

can you try another browser? ideally another machine to access teh piwik site?

Normally, I’m using Firefox but tried it now with Google Chrome (Windows) and on my MacBook with Firefox, Chrome and Safari. Problem occurs on every system.

Hi for fun could you bump up the piwik memory to lets say 512 megs or higher? can you paste how you have the memory defined in the php.ini?,81775,81775

There was a memory issue involving cron to optimize piwik for around 256 megs or under… Im just curious to see if it could be related to that.

The link previous i was pointing to see about browser triggering of reports to be off.

What is the memory for apache in htpp.conf?

When the widgets dont load, the solution is always to check the server error logs to see the exact error, then search the FAQ for this error to find solution

Yes, but the problem is, that there are no errors in the logs. :wink:
Even the expansive value of 512M for memory_limit didn’t change anything.

Black rider, how are applying the piwik Js code? Via an include?

Can you check the suhosin memory limit is not low if applicable?

I don’t have suhosin enabled on my webserver and it’s inserted by using the standard JavaScript code directly into the template of my site.

Did you check

browser trigger archiving?