Piwik 1.7 | Update | Widgets not found


#1

Hello,

today i start automatic update for Piwik 1.7.
No Error, update success.

Now i see no Widgets in Dashboard.
[attachment 499 widgets.jpg]

Can anyone help?


(Matthieu Aubry) #2

That shouldn’t have happened, but you can “Reset” the layout by clicking on “Dashboard & Widgets” and then “Reset”. Sorry about that!


#3

Hello Matt,

I try the reset.
The problem still exists.


(Matthieu Aubry) #4

There appears to be a problem. Delete your browser cache. Then delete files in piwik/tmp/assets/*


#5

ah thanks, that was the missing link…


#6

That doesn´t work for me.

I try this 2 times on different workstations.
Delete Browser Cache and the delete the two files in piwik/tmp/assets/*

The problem still exists.


(Matthieu Aubry) #7

debblitz. try “Reset” the dashboard from the button"Dahsboard & widgets" ?

if not, reupload all piwik files, maybe some files are not uploaded correctly?


#8

I updated both of my piwik installations. The first one was done using the automatic ‘click here’ method and the second was using the direct download of new files(I did the latter because the ‘click here’ method caused the problem noted by the OP) .

Anyway, both updated installations are giving me the ‘widget not found’ problem. But this problem only exists on my HP Touchpad and my Webos phone. Both worked prior to the update.

They work fine in Ubuntu FF and WinXP FF.


(Matthieu Aubry) #9

If it does not work on some browsers only, then delete the browser cache and try again, it should fix it


#10

Still not working after clearing cache and cookies.


(Matthieu Aubry) #11

does the demo work? demo.piwik.org


#12

The demo is working fine on my Touchpad.


#13

Demo works fine on my computer too.

Is there a single file i can check?
What could i upload step by step to solve this problem.
Exists a Special Folder for widgets ?


(Matthieu Aubry) #14

I’m not sure what’s wrong. Can you try create a new user in Piwik and see if the dashboard loads for this newe user?


#15

Using a new user didn’t change anything. I still don’t see any widget content.


(Matthieu Aubry) #16

With this new user, does it load on Firefox, IE, Chrome, etc?
What browser does it not work?

Also can you try with the browsers that don’t work, from another computer / mobile devvice? To check if it is the browser or your device itself?


#17

Same problem here. I tried all of the above, with no success. The only thing left would be a re-install of Piwik.

The update from 1.6 to 1.7 was done by searching and extracting of changes and new files with Winmerge as ZIP archives. The archives were then uploaded via FTP to the web space and extracted using the PHP zip library. Then, the files and folders removed in the new version were manually removed from the server. This was the same procedure as used on previous updates starting from the first used version 1.5.

http://demo.piwik.org works fine.

===========================
Here is the used configuration:

Apache (free shared web space)
(Some things are disabled by provider for security reasons, e.g. allow_url_fopen, etc. - see attached “PHP-Info.pdf” file (created with Joomla on same provider) for details)
PHP/5.3.6
GD Library
PDO MySQL
MySQL 5.1.49-3

===========================
WinXP SP3 32bit
Firefox 10.0.2
Alternatively tested on same machine with same results: Internet Explorer 8 (with all latest patches)

===========================
NOTE: ini_set() calls (the ones without an “@” in front) were commented out ("//") on versions 1.5 - 1.6, because they are disabled by web space provider. On version 1.7, no similar commenting-out was needed, as the previously updated files were not modified on 1.7 and were therefore not re-uploaded.

===========================
The built-in Piwik security plugin shows following error (my website address was removed here by me):
There is an error. Please report the message and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Warning: ini_get_all() has been disabled for security reasons in /srv/www/httpd/phost/r/de/…/web/piwik/plugins/SecurityInfo/PhpSecInfo/Test/CGI/force_redirect.php on line 92

Backtrace -->
#0 Piwik_ErrorHandler(…) called at [:]#1 ini_get_all(…) called at [/srv/www/httpd/phost/r/de/…/web/piwik/plugins/SecurityInfo/PhpSecInfo/Test/CGI/force_redirect.php:92]#2 PhpSecInfo_Test_Cgi_Force_Redirect->_setMessages(…) called at [/srv/www/httpd/phost/r/de/…/web/piwik/plugins/SecurityInfo/PhpSecInfo/Test/Test.php:121]#3 PhpSecInfo_Test->PhpSecInfo_Test(…) called at [/srv/www/httpd/phost/r/de/…/web/piwik/plugins/SecurityInfo/PhpSecInfo/PhpSecInfo.php:276]#4 PhpSecInfo->runTests(…) called at [/srv/www/httpd/phost/r/de/…/web/piwik/plugins/SecurityInfo/PhpSecInfo/PhpSecInfo.php:476]#5 PhpSecInfo->loadAndRun(…) called at [/srv/www/httpd/phost/r/de/…/web/piwik/plugins/SecurityInfo/Controller.php:28]#6 Piwik_SecurityInfo_Controller->index(…) called at [:]#7 call_user_func_array(…) called at [/srv/www/httpd/phost/r/de/…/web/piwik/core/FrontController.php:138]#8 Piwik_FrontController->dispatch(…) called at [/srv/www/httpd/phost/r/de/…/web/piwik/index.php:53]

===========================


#18

Sorry, I meant WinXP SP3 (i.e. latest), not SP2.


(Matthieu Aubry) #19

Can you try to install 1.7 from scratch in another directory for example /piwik2/ – does it work for this one?


#20

a completely new install didn’t work either. Installed at piwik2/
I get the same problem with my HP touchpad and webOS phone.
I am using apache2 on a ubuntu linux system and running MySQL server.
I have all files with 777 permissions.

also created new database