Piwik 1.6 RC released! Call for testers (tu)


(Matthieu Aubry) #1

Piwik 1.6 RC has been released! Note: this version is very safe to use and stable, we already have been testing it for weeks, and most likely will become Piwik 1.6 final release.

We would really appreciate if you can help by downloading and testing this release which contains new features and various fixes and improvements.

Download the ZIP: http://builds.piwik.org/piwik-1.6-rc1.zip

How to update?
To update, simply upload / overwrite all existing files and then visit your Piwik. It contains a few database upgrades, so make sure you run the update in shell if you have a big database. Update Piwik - Analytics Platform - Matomo

What’s new?
Piwik 1.6 is a major upgrade, bringing new features but mostly many bug fixes and small improvements.
[ul]
[li] Ecommerce Tracking improved. New: track “price” on Ecommerce product pages. New: track up to 5 categories for each product page or category page!
[/li][li]Segmentation improved: New segments: visitConvertedGoalId to select visits that converted a specific Goal, and possibility to segment[/url] for [url=http://piwik.org/docs/custom-variables/]Custom Variables of any scope (visit or page)
[/li][li] Dashboard: widgets can now be minimized and maximized for easier analysis
[/li][li] Many bug fixes and improvements, see the ticket list for details on the 75 tickets closed!
[/li][/ul]

Check out the list of closed tickets for this release for more bug fixes and new features: adding support for windows phone 7 version 7.5 by thirashima · Pull Request #1 · matomo-org/matomo · GitHub

Please post any issue or question in this post, thank you for your help testing!!


#2

Greetings!

I’ve updated to this stable release - 1.6 rc1 and am currently experiencing odd behavior with the following segmentation:

entryPageURL
entryPageTitle
pageTitle
pageURL

When I try to segment with any of the variables above, Piwik returns an empty log. Zeros all across the board. This behavior was not occurring in 1.5.1.

Please investigate.

Thanks!


(Matthieu Aubry) #3

Working for us:

pageUrl: http://demo.piwik.org/index.php?module=API&method=Referers.getKeywords&format=XML&idSite=7&period=day&date=yesterday&filter_limit=100&segment=pageUrl==http%3A%2F%2Fforum.piwik.org%2F

entryPageUrl: http://demo.piwik.org/index.php?module=API&method=Referers.getKeywords&format=XML&idSite=7&period=day&date=yesterday&filter_limit=100&segment=entryPageUrl==http%3A%2F%2Fforum.piwik.org%2F

what exact URL do you use that is not working?


#4

After entering the database details during piwik 1.6 setup… getting this error. Please help

Fatal error: Out of memory (allocated 6291456) (tried to allocate 4294967294 bytes) in /opt/piwik/libs/Zend/Db/Statement/Mysqli.php on line 255


#5

Hey guys looks good and everything is working so far. Gonna stress test and compare to the previous version. However, when trying to run the archive.php script I get this:


./archive.php: line 1: ?php: No such file or directory
./archive.php: line 2: =: command not found
./archive.php: line 20: =: command not found
./archive.php: line 82: syntax error near unexpected token `'PIWIK_INCLUDE_PATH','
./archive.php: line 82: `define('PIWIK_INCLUDE_PATH', realpath( dirname(__FILE__)."/../.." ));'



#6

Noticed another issue.

Anytime I use the Website “Drop Down List” we get a Invalid Response:

http://*********index.php?module=CoreHome&action=index&period=day&date=today&idSite=9

This happens with all of the sites but the default option


(Matthieu Aubry) #7

JMETERX, what do you mean exactly by "Anytime I use the Website “Drop Down List” we get a Invalid Response: " ?


#8

Uploaded the latest version (1.6) and get this when changing the date in the overview to “today”:

"SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘idaction_category2’ in ‘on clause’

Backtrace:
#0 /var/www/example.com/piwik/libs/Zend/Db/Statement.php(300): Zend_Db_Statement_Pdo->_execute(Array)
#1 /var/www/example.com/piwik/libs/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /var/www/example.com/piwik/libs/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query(‘SELECT???na…’, Array)
#3 /var/www/example.com/piwik/core/Db/Adapter/Pdo/Mysql.php(211): Zend_Db_Adapter_Pdo_Abstract->query(‘SELECT???na…’, Array)
#4 /var/www/example.com/piwik/core/ArchiveProcessing/Day.php(376): Piwik_Db_Adapter_Pdo_Mysql->query(‘SELECT???na…’, Array)
#5 /var/www/example.com/piwik/plugins/Goals/Goals.php(566): Piwik_ArchiveProcessing_Day->queryEcommerceItems(‘idaction_catego…’)
#6 /var/www/example.com/piwik/plugins/Goals/Goals.php(473): Piwik_Goals->archiveEcommerceItems(Object(Piwik_ArchiveProcessing_Day))
#7 [internal function]: Piwik_Goals->archiveDay(Object(Piwik_Event_Notification))
#8 /var/www/example.com/piwik/libs/Event/Dispatcher.php(284): call_user_func_array(Array, Array)
#9 /var/www/example.com/piwik/core/PluginsManager.php(609): Event_Dispatcher->postNotification(Object(Piwik_Event_Notification), false, false)
#10 /var/www/example.com/piwik/core/ArchiveProcessing/Day.php(42): Piwik_PostEvent(‘ArchiveProcessi…’, Object(Piwik_ArchiveProcessing_Day))
#11 /var/www/example.com/piwik/core/ArchiveProcessing.php(440): Piwik_ArchiveProcessing_Day->compute()
#12 /var/www/example.com/piwik/core/Archive/Single.php(224): Piwik_ArchiveProcessing->launchArchiving()
#13 /var/www/example.com/piwik/core/Archive/Array/IndexedBySite.php(85): Piwik_Archive_Single->prepareArchive()
#14 /var/www/example.com/piwik/core/Archive/Array/IndexedBySite.php(58): Piwik_Archive_Array_IndexedBySite->getValues(Array)
#15 /var/www/example.com/piwik/plugins/VisitsSummary/API.php(79): Piwik_Archive_Array_IndexedBySite->getDataTableFromNumeric(Array)
#16 /var/www/example.com/piwik/plugins/MultiSites/Controller.php(64): Piwik_VisitsSummary_API->get(‘all’, ‘day’, ‘2011-10-18’, false, Array)
#17 /var/www/example.com/piwik/plugins/MultiSites/Controller.php(37): Piwik_MultiSites_Controller->getSitesInfo()
#18 [internal function]: Piwik_MultiSites_Controller->index()
#19 /var/www/example.com/piwik/core/FrontController.php(132): call_user_func_array(Array, Array)
#20 /var/www/example.com/piwik/index.php(53): Piwik_FrontController->dispatch()
#21 {main}"

When logging in, it was not asking for upgrade it simply just switched to the overview of “yesterday”.
It displays version 1.6


(Matthieu Aubry) #9

sieg01 , from what version were you updating from?

run the following query in your mysql database:


UPDATE `piwik_option` SET option_value = "1.5.1" WHERE option_name = "version_core";

if you were updating from 1.5.1 - does it work fine after this?


#10

Yes, it was asking for the upgrade now.

And for the moment everything looks fine, except the Germanic umlauts are broken since I uploaded 1.6 for new visitors
It shows “polkupyã¶rã¤n perã¤kã¤rry” instead of “polkupyörän peräkärry”

Update/Change: more specific defined the bug


#11

Hi all!

After update to 1.6 i have trouble with russian letters in search keywords, it looks like this:
“ð±ð¸ð±ð¾ññ”


#12

Hello!

I’ve update within the interface, but now my dashboard is empty. All “subpages” works fine, but the dashboard stays empty, even after a few minutes waiting. I’ve added the widgets manualy and that works after relogin.

Kind regards
crazyiven


#13

Its me again :slight_smile:

I’ve created a new user … still empty dashboard. But when I add a DB entry in table “piwik_user_dashboard” with the Values:
Login Name “login”, iddashboard “1” and layout “[[],[],[]]” (found it in one user where i played with the dashboard). Now the dasboard works just fine and all widges shows up … if i delete this entry, the dashboard stays empty like right after the update.

So i think there’s something wrong with the “default dashboard” if no “own dashboard” in table “piwik_user_dashboard” is definded? Or the system doesn’t create db entrys for old & new users? I’m a webprogrammer myself and just guessing … might be a help?

Kind regards
crazyiven


(Matthieu Aubry) #14

sieg01, iskander, thanks for the report. Can you please replace your piwik.js file with the trunk version?
http://dev.piwik.org/svn/trunk/piwik.js

I have fixed the issue there but would be great if you could confirm that the data is now tracked correctly.

Thanks!


(Matthieu Aubry) #15

Thank you for the report! the bug is fixed in: http://dev.piwik.org/trac/changeset/5327

I will repackage 1.6 to include these fixes hopefully not many people have already updated.


#16

[quote=matt]

Thank you for the report! the bug is fixed in: http://dev.piwik.org/trac/changeset/5327

I will repackage 1.6 to include these fixes hopefully not many people have already updated.[/quote]

So my first thought about problems with default handling was right :). I’ll change the Controller.php file … thx for the fast help :). There was a mate in the german board, I’ll tell him how to fix the problem.

Kinds regards
crazyiven


#17

100 points.
It fixed it. :slight_smile:

Thank you!


(Matthieu Aubry) #18

NICE! thanks for quickly confirming


#19

Changing Controller.php in /plugins/Dashboard solved my problem. Thx for the help, explained this fix to the german board aswell :slight_smile:


#20

Matt - any website you select from the drop down bar gives us an error on the page. THe drop down bar is in the upper right hand corner you click it and select another site and it won’t load but the stock one. Looks like others are starting to have this issue as well.