Page views & events visible in user profile, but not in "Behaviour" tab

Using ngx-matomo I’ve setup some test events and page views which are registering in the Matomo dashboard and clearly visible when I click “view user profile”, see screenshot. However, these navigations and events are not showing up in the “behaviour” tab under “pages” or “events”

This is the module setup:

    MatomoModule.forRoot({
      scriptUrl: `${matomoUrl}/matomo.js`,
      trackers: [
        {
          trackerUrl: `${matomoUrl}/matomo.php`,
          siteId: 3
        }
      ],
      routeTracking: { enable: true }
    }),

and on every NavigationEnd I’m logging a page view, which is being executed on every navigation:

  trackPageView(page: string) {
    this.matomoTracker.setCustomUrl(page);
    this.matomoTracker.setDocumentTitle(page);
    this.matomoTracker.trackPageView();
  }

this is used for event tracking:
this.matomoTracker.trackEvent(category, action, name, value);

Why are these page views and events only showing up on the dashboard, but not under behaviour?
Yes, I’m looking at the right day & website, stuff is showing up, just not where it should be.
Thanks very much, completely stuck here.

update: does this have something to do with “url segmentation”?

Isn’t it a problem of log archiving?
See Can see myself in real time, not in detailed historical report - Support & Bugs - Matomo forums

Edit: No because we’re on the cloud version of Matomo, where this doesn’t seem to apply.

This setup has worked before without playing with these settings. Just not sure what was different then, but it was in code config. Isn’t this related to url segmentation?

Ok this DOES seem to be an archiving issue because suddenly all my previous events of the day are showing up. Where / how exactly can I enable auto archiving?

This setting doesn’t seem to be available because we’re running the cloud version?
Is this something we have no control over and we only see reports from previous days?

As you are on the cloud, maybe you can ask by email to Matomo sales service…