No images

Hi all

I’m a bit lost here. I recently installed Piwik 1.4. Installation seemed to work fine but Piwik does not show any images like the Piwik logo or icons. Also the graph does not seem to work.

[attachment 218 piwik_error.png]

Also the login page is displayed in plain html, no css. I both re-installed and re-uploaded Piwik, no difference. When running the installation process again I noticed that no images are displayed, too (the green checks for example). I checked for the images in the themes folder, they are there.

I got no problems with the site. I am also running another Piwik installation off a different site with no problems, same web space provider and similar settings. Only difference I know of is that version 1.4 installed by updating.

Tested this on two different Macs with Safari 5.0.5, Firefox 4.0.1, OS X 10.6.7.

I already tried the suggestions made in this thread.

  • cleared the cache
  • deleted htaccess files in the tmp folder
  • changed chmod to 777
  • switched language to English

I’d like to try an older installation of Piwik. Where can I find the 1.3 or else installer?

Any other suggestions so far? Thx in advance…

No one?

Maybe I am too stupid, but someone please point me to an earlier version of Piwik. I will try myself from there…

Try to delete the directory and files inside tmp/assets/ whichs hsould fix this issue

Thanks matt

but unfortunately that does nothing. Should I re-upload and try deleting the assets folder again?

Yes but please try the latest RC instead 301 Moved Permanently

Still (nearly) the same problem.

I deleted the old installation and installed 1.5 RC 6, still no images in the installation process. That way I cannot even see if Piwik finds any problems with the server setup because the red and green check marks are missing. Then I deleted the tmp/assets folder. BTW: I did not have the option to migrate the old database but to choose to delete/recreate or use another prefix. Is that last option the migration?

On the dashboard the Piwik logo and graphs are now showing. But the icons are still missing. Funny, since they share the same folder.

The missing icons make it impossible, for example, to set user permissions:

[attachment 220 PIWIKuserpermissions.png]

Login screen is still plain HTML:

[attachment 221 PIWIKloginscreen.png]

Are there any files in tmp/assets? this directory must be writeable.

There were files in there… until I deleted it… B)

Should I recreate the directory? All should be (have been) writable, CHMOD 710 I think…

Ah well yes… Took a quick look again. It got recreated all by itself of course… (:P)

So yes, there are files in there.

is there a url to see this in action? or could you install firebug for firefox and see in the network tab whats happening to the requested images?

Thanks Thomas, very helpful. Firebug shows “500 internal server error”. Just activated the server logs. Will have to wait overnight to be able to access them.

Interestingly the piwik header logo (logo-header.png) is diplayed correctly but firebug also reports the error there. Guess I will have to investigate the server logs then?

Yeah, the server(error-)logs will tell you. I guess some htaccess or permission issue.

Finally got to take a look at the logs. All I get is a lot of stuff like this: - - [09/Jun/2011:16:02:08 +0200] “GET /themes/default/images/export.png HTTP/1.1” 500 808 “” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1”

So no news except that 808 as far as I understand it. Does that 808 provide any useful information on my problem?

thats the access log but you need the error log.

doh! seems I have to contact the webspace provider for the error logs…

Ok, the apache ERROR logs show continously errors which contain the phrase

“… .htaccess: deny not allowed here …”

The webspace provider tells me my package has not all .htaccess features enabled. To be more exact they seem to be more or less non-existant. I recall having modified (or maybe deleted?) specific .htaccess files in my other Piwik installation to get it working after reading an article here in the forums or maybe in the FAQs. But I cannot find that article anymore.

What should I do? Just delete every last .htaccess file from the current Piwik installation?

Yes, in this case, you’ll have to delete the .htaccess files. But before you do that, send the contents of some of the .htaccess files to your hosting provider to show them what they do. Specifically, these provide an additional layer of security, and without them, your Piwik installation is vulnerable to information disclosure (e.g., directly accessing some .php files may leak path information).

Thanks Anthon, will do that.

My hosting provider sells more expensive packages that provide all the .htaccess features (and much more). But since Piwik is the only application that needs those features at this particular website – and the collected data is not exactly highly classified – ordering a bigger package seems not really reasonable. In other words: I guess since I refuse to spend more money, my provider could not care less… :sunglasses:

It’s up and running nicely! I deleted (renamed) the .htaccess files in these folders: lib, misc, tmp+subfolders.

Thanks to everyone for the help!

resolve it now???