No graphs


#1

hi community,

i*m quite new at piwik so maybe my questions are trivial for you.

  • Like you can see on the images, piwik does not show me any graphs. no world map, no visitor graphs.nothing.
  • i have some files for downloading on my site, but piwik does not show me the downloads, there is only: no data.

thank you for your help
manuel


(Matthieu Aubry) #2

You should install flash 10 to see graphs.


#3

hi matt,
thanks for your fast reply.

flash 10 is already installed. i tried on 3 different browsers and two different computer. i have everytwhere the same problem.
adblock is also deactivated.

i noticed on safari and chrome that i have also missing images on my piwik site,maybe it has to do with my problem.

cheers


(theodorius123) #4

same problem here with firefox 4.0b8…

-updatet to Piwik 1.1.1 (came from 1.0)
-disabled all addons
-uninstalled and reinstalled flash player
-cleared the cache

but nothing… :frowning:

the only thing that is different here is that it works with IExplorer.

any other ideas?

thanks!


(Matthieu Aubry) #5

Can you try to set language to english? IF it is working in english, what language were you using?


#6

hi,

i’m using german. in english the same problems here.


(theodorius123) #7

same here…language makes no difference…


#8

Hi,

I’ve the same problem also since I updated to Piwik 1.1.1

Any solutions?

Is it possible to go back to Piwik 1.0 ? How ?

Thanks


(Matthieu Aubry) #9
  1. Do you also have the same problem on the demo.piwik.org ?

  2. Another user said that disabling the PDF reports fixed the graph issue. Can you try this and confirm?

  3. what browser, OS and flash version are you using?


(theodorius123) #10
  1. yes, same there - no graphs
  2. disabled, same problem :frowning:
  3. FF 4.0b8, Flash 10.1 (download from yesterday) with Win7 64

in my case it is working with IExplorer, so I tried it with a completly new Firefox-Profile - but again, does not solve the problem


#11
  1. the demo works fine. i noticed that on my piwik (not demo) i miss also the the little images (export, table ecc.) on the bottom of the widgets
  2. only tables, no graphs
  3. safari 4, safari 5, firefox 3.6, chrome 8 / flash 10.1 / osx 10.6.5, osx 10.5.8

(micro kaynak) #12

my friend has get that problem to, i’ll ask about him how he was fix that…


(vipsoft) #13

it looks like your systems are not configured to use .htaccess files.

A number of .htaccess files are created during installation to protect files from direct access. This is part of the multi-layer security. Exceptions are made for images and .swf.

If the graphs and images aren’t loading, then you need to either configure Apache to use .htaccess files (see Options) or remove the .htaccess files (they won’t be recreated).


#14

i removed the .htaccess files and nothing changes. i´m quit sure that my webspace allows and supports .htacces, otherwise the downloadable files on my site wouldnt work.

i think that it has something to do with a bad installation of piwik. i would like to reinstallit but i dont want to loose my stats.

how can i reinstall it withput loosing my data? or any other suggestions?


(vipsoft) #15

It’s ok to re-run the installer. Just select “Reuse existing tables” when you get the prompt.


#16

great! now it works fine.
reinstalling piwik solved the problem with the graph.

thanks a lot


(theodorius123) #17

@ grinder: lucky you! :wink:

But I still have the problem.

No idea what it is - it is not my piwik (demo is not working too and everything is fine in IExplorer)
I tried a complete new profile in Firefox - without any improvement.

what is wrong here? grrrrrr.

would be great if someone has another idea. THANKS!


#18

i think this has something to do with your browser.
try to install chrome, safari or others… if they all work so i’m sure that the problem is firefox or some plugin like adblock & co.
maybe try also to deactivate all your firefox plugins and addons

i hope it will work


(vipsoft) #19

theodorius123: go into tmp, and delete the files in tmp/templates_c/* and tmp/assets/*; then clear your browser cache


(theodorius123) #20

[quote=grinder]
i think this has something to do with your browser.
try to install chrome, safari or others… if they all work so i’m sure that the problem is firefox or some plugin like adblock & co.
maybe try also to deactivate all your firefox plugins and addons

i hope it will work[/quote]
yes, it must be something with firefox. everything fine with IExplorer.
I also tried a complete new firefox-profile - without any addons…
so I realy don’t know whats the problem.

[quote=vipsoft]
theodorius123: go into tmp, and delete the files in tmp/templates_c/* and tmp/assets/*; then clear your browser cache[/quote]

thanks, but it doesn’t fix it :frowning: