No data with Heatmap & Session Recording


#1

hello, I’m new with matomo, I installed the “heatmap” plugin, called the first Heatmap:
Target page rule: url -> starts with -> "https://sitename.com/it/"
sample rate -> 100%
etc …

but I have no data collecting

“No page view has been recorded yet for this heatmap. If there are supposed to be recordings by now, maybe the page targets configured for this heatmap do not match any page on your website. It is also recommended to check the “System Check” under “Administration” (only Super Users) to see if your system is configured to automatically track Heatmaps.”

the matomo web server is behind a firewall,
the system check gives me:

We couldn’t check if ‘https://myMatomoInstallation/piwik/plugins/HeatmapSessionRecording/configs.php?idsite=1&trackerid=5lX6EM&url=http%3A%2F%2Ftest.test%2F’ is accessible because the internet connection is disabled on this Matomo. Please open the URL manually in a browser to see if the response contains ‘Piwik.HeatmapSessionRecording’. If not, you might need to modify your server configuration as this file needs to be accessible via a browser from the Internet or Intranet.

if i open manually the url is ok
"Piwik.HeatmapSessionRecording.configuration.assign({“heatmaps”:[],“sessions”:[],“idsite”:1,“trackerid”:"…"

some idea?

thanks


(Matthieu Aubry) #2

Hi there,

Please find our reply below:

  1. Firstly, please check that the “Starts with” makes sense in your case
    -> Often, we recommend to use “Equals simple” comparison to setup Heatmaps.

  2. In the Heatmap edit page, could you check that your Page URL on which you want to track the heatmap matches? Using the URL validator tool:

If the URL validates correctly, then the Heatmap should be tracked.
If it is still not tracked, please send us an email to shop at innocraft.com and we will troubleshoot further.

Thanks,


#3

Thanks for the reply,
I changed the setting in “Equals simple”,
the check with the URL validator tool is ok


#4

Hello,

I have the same problem:

I’ve checked the “System Check” - seems to be ok.

I’ve also used the URL validator

So there should not be a problem with heatmap recordings?! What else can I do?

Thanks