New version, new user, no place to enter password

After upgrading to the latest version.
There is no place to enter a password for a new user.
Later, I saw that I needed an email invitation, then I sent an email, clicked connect, and the error page was displayed.
so much trouble. How to go back before. Or, when creating a new user, the general administrator can set M

This is a new feature:

You can either create an user via the API:

Can you display screenshot?
Is there any JavaScript error in the browser console?

I don’t want to send invitations to new users. I imagine that the user name and password of a new user can be created directly above. If not, how can I return to the previous version

My trial environment is like this. I manage many websites of my clients. I need to create an analysis system for them all. And call the statistics API through their website background. I’m the chief administrator. All users and passwords should be created by the administrator. I don’t want to invite my clients.

Please help me, thank you

Users are still created by the administrator…
The only thing that has changed is that you don’t have to manage password, the new user (you created and invited) will set his password himself. You don’t have to loose time to manage their password. And no need to send an email containing a temporary clear password.

Version rollback is not advised, as it could lead to unstable behaviour (eg. if vNext did remove some column in a MySQL table)… But you can try to download the previous version and copy its files in the Matomo folder. (don’t forget to backup, just in case…)

As previously written, you can still create a user and define its password via the API:

1 Like

I like you to switch back to the previous settings. The user name and password can be set by the administrator. Now the new version is completely logical.
Why do I invite my customers to create it. They are not familiar with the system at all.

I am just a volunteer who helps on forums, I won’t be able to switch anything.

Sorry I don’t understand what you mean…

In order to hot have to manage their password. This is a security behaviour.

Not need to be familiar to anything to set-up a password at first logon:

This is the invitation link error

Does this message appear instead of the invitation acceptation form (see below)?

Hi LeiBei,

This new way is more secure: the administrator and the email will have no recording of the password. And this should be less work for you, since there are fewer configuration steps.

Sorry to see there is an error screen showing. Maybe the problem occurs at the level of emailing. Does the error go away if you change your network environment? (Different browser, different machine, connect to the network in a different way…)

FYI I’ve written an example of the API usage for creating a user through that method (Using the Users Manager API method) in this forum post: 4.11.0: can't set new user passwords, but user invite emails not sent - #3 by rstark

There is also some information on testing emails on your Matomo server which could be useful in troubleshooting the issue here.

1 Like