Matomo-Deaktivierung funktioniert nicht


#1

Hallo zusammen,

ich nutze Matomo (Piwik) eigentlich schon länger. Wegen dem aktuellen Wirbel in Sachen Datenschutz habe ich mir die Deaktivierung nochmals angesehen und mittels Browser Addon Ghostery festgestellt dass Piwik weiter trackt, obwohl ich das Häkchen entfernt habe.
Ein Blick auf die Check-Box zeigt, dass nach dem Seitenwechsel oder auch nach einem einfachen refresh der Seite das Häkchen wieder gesetzt ist.
Ein Test an einem anderen PC brachte dasselbe Ergebnis. Bislang fühlte ich mich mit Piwik in Sachen DS auf der sicheren Seite… jetzt bin ich ziemlich verunsichert.
Ich hoffe schwer, dass es da Abhilfe gibt.

Vielen lieben Dank schon mal vorab und liebe Grüße
moal


(Lukas Winkler) #2

Hallo,

Erstmal zeigt Ghostery nur an, dass Matomo in der Seite eingebunden und geladen ist (was es ja nach dem opt-out immer noch ist).

Das Häckchen sollte aber wirklich nicht wiederkommen.

Kannst du mal ausprobieren, ob dieses Opt-Out richtig funktioniert?
https://matomo.org/privacy-policy/

Ansonsten kannst du mir gerne einen Link zu deinem Opt-Out schicken und ich schaue es mir an.


#3

Hallo, vielen Dank für deine Antwort.
Ghostery würde mich nicht mal so stören, wenn das Häkchen nicht wie von Geisterhand wieder aktiviert wäre.
Auf der verlinkten Seite funktioniert es. Warum nicht bei mir?

Der Link geht gleich per Nachricht raus.
liebe Grüße
moal


#4

Kleiner Nachtrag… wenn ich auf der verlinkten Seite das Kästchen deaktiviere, zeigt mir Ghostery übrigens Piwik nicht mehr an. Auch nicht, wenn ich auf die Startseite https://matomo.org/ wechsle.
liebe Grüße :slight_smile:


(Lukas Winkler) #5

Hallo,

Zu Ghostery kann ich nicht viel sagen, weil ich nicht weiß, wie es funktioniert.

Aber bei mir ist auf deiner Seite auch dasselbe Problem. Ich finde aber nicht heraus woran es liegt.

Ich werde mal weiterfragen und vielleicht fällt mir noch etwas ein.

Denn das das Opt-Out funktioniert ist fundamental.


#6

Dankeschön!
Ich weiß ja nicht, ob es damit zu tun haben kann, aber ich frage einfach mal. Mein Piwik ist eine alte Installation aus Piwikzeiten, also vor Matomo. Die ist auch schon mal “umgezogen” auf einen Server mit Sicherheitszertifikat. Heute habe ich in der Adminkonsole gesehen, dass es einige Meldungen beim Datei-Integritätscheck gibt. Unter anderem wurden Unmengen Dateien aufgelistet die ich löschen sollte. Das habe ich auch weitestgehend umgesetzt… bis auf einige Dateien verschiedener Verzeichnisse die jeweils Menu.php heißen. Lösche ich diese Dateien wie gefordert, komme ich beim refresh der Seite nicht mehr zurück in den Adminbereich. Ich erhalte dann eine Fehlermeldung nach der Anderen zu den fehlenden Dateien. Erst wenn ich diese Menu-Dateien wieder hergestellt habe, komme ich wieder in den Adminbereich.
Sollte ich vielleicht die Piwikinstallation komplett neu aufsetzen? Oder gibt es da eher keinen Zusammenhang?

liebe Grüße


(Lukas Winkler) #7

Hallo,

Damit hat es nichts zu tun, da empfehle ich falls einmal Zeit ist den kompletten Matomo-Ordner mit der neuersten Version zu ersetzen und nur die config-datei beizubehalten.

Ich habe das Problem aber schon gefunden, bin aber ratlos wie man es lösen kann. Vermutlich braucht das (recht bald) eine Lösung seitens Matomos:

Das Opt-Out funktioniert indem es einfach ein cookie names piwik_ignore auf die Domain von Piwik setzt.
Ich vermute aber, dass du Chrome verwendest und in den Einstellungen

Drittanbieter-Cookies blockieren
Websites von Drittanbietern am Speichern und Lesen von Cookiedaten hindern

aktiviert hast. Dadurch darf aber deine Webseite (die auf einer anderen Domain als dein Matomo liegt) keine Cookies auf die Matomo-Domain setzten und somit kein Opt-Out cookie erstellen.

Die Lösung wird vermutlich sein, dass Matomo in Zukunft das Opt-Out Cookie auf die Domain der Webseite setzt.
Aber das macht einiges komplizierter und ich bilde mir ein, dass das Setzen des Cookies im iFrame früher funktioniert hat.


#8

Hallo,

das ist ja blöd. Ich habe die Installation auf die andere Domian gelegt, weil ich bei meinem Provider je Paket nur ein Zertifikat frei habe. Da ich zwei Pakete habe und das Zertifikat in dem anderen Paket nicht benötige habe ich Piwik da rüber verfrachtet. Eine unsichere Verbindung für Piwik ist ja auch nicht wirklich eine Lösung des Problems. In einem Jahr steht ein Provider-Umzug an. Da wird dann wieder beides auf einem Server liegen. Deine Vermutung mit dem Browser trifft allerdings nicht zu. Ich nutze fast ausschließlich den Firefox. Auch bei meinen Test bezüglich des Problems. Und irgendwelche Maßnahmen zum Unterbinden von Cookies habe ich da eigentlich auch nicht getroffen.
Wenn diese Browsereinstellung diese Auswirkung hätte, müsste man ja aber fast darauf hinweisen. Man weiß ja nie, mit welchem Browser die Besucher kommen und wie sie ihre Einstellungen vorgenommen haben.
Klingt als würde es keine zeitnahe Lösung für mein Problem geben. Was würdest du an meiner Stelle nun tun?
liebe Grüße und besten Dank!


(Lukas Winkler) #9

Hallo,

Ich habe das Problem mal weitergeleitet. Es ist aber gerade Wochenende, also kann es vermutlich bis Montag dauern.


#10

Das ist nett. Vielen Dank für die Mühe und ein schönes Wochenende. :slight_smile:


#11

Hallo, ich habe heute das neue Update installiert. (Matomo in das Wordpress-Verzeichnis?) Leider brachte es bei meinem Problem keine Veränderung.
liebe Grüße


(Carsten Falkenberg) #12

Ich habe die Erfahrung gemacht, dass das Optout scheinbar nicht funktioniert, wenn sich die Piwik/Matomo-Domain im Tracking-Code und beim Optout-Iframe unterscheiden, also z. B. einmal mit, einmal ohne www.

Es kann also sein, dass dein Tracking-Code z. B. auf www.tracking-domain.de hört, in dem Cookie vom iframe aber nur tracking-domain.de (also statt www.tracking-domain.de) steht. Dann werden weiterhin Daten erfasst.


#13

Daran liegt es hier leider nicht, aber danke. Piwik liegt auf einem anderen Server als die Seite selbst. Das Update sollte Abhilfe schaffen, tut es aber leider nicht.


(David Stingl) #14

Ich habe dasselbe Problem hier: Datenschutzerklärung | Craft Bier Geek
Wenn ich den Haken im Matomo-iFrame (auf der Seite steht noch Piwik) entferne, ist er manchmal sofort wieder da, manchmal auch vorübergehend verschwunden. Spätestens nach zweimaligem Neuladen der Seite ist der Haken jedoch wieder da.
Meine Matomo-Installation liegt auch auf einer anderen Domain.


(Lukas Winkler) #15

Hallo @moal72 und @berlindave,

Das Problem ist, dass dies sich nicht wirklich einfach lösen lässt, da es eine Einstellung des Browsers ist keine Cookies von 3rd-party-domains anzunehmen.

Die Lösung, die ich oben erwähnt habe ist zwar in 3.5.0 enthalten, aber vermutlich nicht so umfangreich, wie ihr es euch wünschen würdet:

Denn damit der Opt-Out gespeichert werden kann, muss das cookie also auf die Domain der Webseite gespeichert werden. Das darf aber glaube ich wiederum das iFrame nicht (weil es ja von einer anderen Domain kommt.

Mit 3.5.0 könnt ihr aber die folgenden Funktionen nutzen, um für die Seite ein eigenes Opt-Out zu bauen:

var tracker = Piwik.getAsyncTracker()
console.log(tracker.isUserOptedOut())
tracker.optUserOut()
console.log(tracker.isUserOptedOut())
// tracker.forgetUserOptOut()

Alternativ kann man natürlich immer anstatt des iFrames auf das Opt-Out verlinken, denn so kommt der Besucher auf die Matomo-Domain.

Oder meine Lösung zu dem Problem ist es für jede Webseite einen A-Record (oder CNAME) auf meinen Server zu setzen und dann Matomo einfach unter allen Domains laufen zu lassen. (Sodass also matomo.webseite1.example, matomo.webseite2.example undmatomo.webseite3.example alle auf dieselbe Matomo-Instance zeigen)


(David Stingl) #16

Danke, @Lukas, für die ausführliche Erläuterung des Problems. Nun weiß ich wenigstens, woran es hakt. Besten Dank auch für die diversen Problemlösungsansätze!


#17

Das stimmt aber ja so nicht. Ich habe keinerlei Einstellungen in meinem Browser vorgenommen die Cookies von Drittanbietern ablehnen. Ganz im Gegenteil.
Wenn aber die Einstellungen jedes Besuchers, der diese Browsereinstellung vorgenommen hat, ignoriert werden, kann ich Piwik/Matomo nicht als unbedenklich in Sachen DS einstufen. Kein Abmahnanwalt wird sich dafür interessieren, ob die Browsereinstellung des Besuchers Schuld am geschiterten optout ist. Ganz im Gegenteil. Vermutlich wird sich das schnell rumsprechen und man wird gezielt nach diesen Kandidaten ausschau halten um sie abzumahnen.
Um ein eigenes OptOut zu bauen, fehlen mir leider die Kenntnisse, auch die zweite Lösung zaubert mir nur Fragezeichen auf die Stirn. Ich bin Anwender und habe keine Programmierkenntnisse.
Und ob es langfristig zulässig ist auf eine andere Seite zu verlinken ist auch noch fraglich. Siehe wieviel Klicks bis zum Impressum etc.

Liebe Grüße


(David Stingl) #18

@moal72, hättest Du die Möglichkeit, Matomo auf einer Subdomain zu Deiner zu trackenden Website zu installieren? Bei einer meiner Installationen liegt Matomo auf piwik.meinedomain.tld, da habe ich keine Probleme. Probleme entstehen nur, wenn ich auf Matomo auf einer völlig anderen Domain zugreife.


#19

Ich weiß, ich hatte es bis vor kurzem auf einer Subdomain. Da habe ich es runter genommen, weil ich für diese Domain kein Zertifikat habe. Ich habe aber ein zweites WH-Paket, in dem ein Gratiszertifikat frei war. Deshalb der Umzug von Piwik. Danach bemerkte ich zufällig das Problem. Ich generiere mit dem Blog 0 Einnahmen und müsste für das Zertifikat für die Subdomain monatlich 8 Euro zahlen. Das ist mir zu viel. Dann muss ich auf Statistik leider verzichten.

Liebe Grüße


(Lukas Winkler) #20

Hallo,

Ich glaube, dass hier das eigentliche Problem anfangt. Man sollte niemals darin limitiert sein, wie man seine Webseiten strukturiert, nur weil man Kosten minimieren will. Subdomains kosten nichts und SSL-Zertifikate auch nicht (siehe Let’s Encrypt).

Nur leider lässt sich das Shared-Hostern, die vor einigen Jahren in der Zeit stehengeblieben sind, das schlecht mitteilen.