Login impossible


#1

Hi,
I’am using Piwik since quiet va long time.For some reasons I had to delete and start again to Matomo.I’am also using WP-Piwik on wordpress which works fine. My problem is that I cannot login to Matomo as a superuser. When I login as anonymous, I can see everything works ok.
So why cannot I login as superuser?
Any help would be welcome!
Thanks


(Fabian Dellwing) #2

Can you provide an error message?


#3

Only this error, again and again


(Fabian Dellwing) #4

Ok, please try to use the “Forgot password” (Mot de passe perdu) function first, if that doesn’t work try How do I change the Super User’s password when password recovery emails are not sent? - Analytics Platform - Matomo


#5

That’s what I did, get a mail as answer, but without any result.


(Fabian Dellwing) #6

So, with the new password and the given email adress you were unable to login?


(Lukas Winkler) #7

A post was split to a new topic: Login doesn’t work after Setup


#8

Hi
Sorry but this doesn’t work neither:

Erreur

**Requête SQL : **

``

UPDATE `matomo_user` SET `password` = "$2y$10$FdIxj5r/oQn6F6ezMtv/W.QjaajouskINZY.buhYLpOR5pIpjRwNi" WHERE `login` = ‘foodstyling’ AND superuser_access = 1

**MySQL a répondu : **Documentation

#1054 - Champ '‘foodstyling’' inconnu dans where clause


(Lukas Winkler) #9

Hi,

You should be using normal quotes ->'<- or ->"<- instead of typographical quotes around foodstyling.


#10

Thanks, the query is ok now, but still no access with admin and changeMe as credentials


(Lukas Winkler) #12

(Lukas Winkler) #13

Hi,

I temporarily made this hidden, as you posted username and password.

With the SQL query you changed the password of the foodstyling user.

So you need to login with foodstyling and changeMe.


#14

Thanks,
The query is working now, but still no access, admin and changeMe


#16

Hi,

Thanks for your quick answer, but still not working.


(Lukas Winkler) #17

Hi,

It seems like you have now given your anonymous user admin access. (Which means that everyone opening https://www.foodstyling.be/matomo/ has full admin access on the site.
I’d recommend you take a look at the matomo_user MySQL table, set the anonymous user to non-admin there and then login using the foodstyling user.


#18

I set anonymous to 0, tried to access matomo and this is what I get,


(Lukas Winkler) #19

Perfect,

Now you enter foodstyling in the first box and changeMe in the second box.
It works for me, so if it doesn’t for you, please try it with a different browser.


#20

Finally I can login with Firefox, but not with Safari mac (maybe a cooky?)
Thannks for your help!


(Lukas Winkler) #21

Please update your username and password and reset your authToken immediatly so that noone else can access them.


#22

That’s what I did, I can login now with Chrome and Firefox but not with Safari. Any clue to fix that?