Failed to load HTML file: Please check your server configuration. You may want to whitelist "*.html" files from the "plugins" directory. The HTTP status code is 403 for URL "plugins/ZenMode/angularjs/quick-access/quick-access.html"


#1

Failed to load HTML file: Please check your server configuration. You may want to whitelist “*.html” files from the “plugins” directory. The HTTP status code is 403 for URL “plugins/ZenMode/angularjs/quick-access/quick-access.html”

Worked fine before the update, and I’m not sure what that plugin is.


#2

Getting the exact same error. Piwik seems to be working fine so far though.
Directory permission is 750 and file permission for this file is 664


#3

Found the fix in an earlier post by DavidY

I fixed the problem by changing the permissions from 750 to 755 of:

/plugins/ZenMode/
/plugins/ZenMode/angularjs/
/plugins/ZenMode/angularjs/quick-access/


#4

Attention !!!

Il y a un bug dans le fichier piwik\plugins\Installation\ServerFilesGenerator.php

Ce fichier sert entre autre a créer un fichier web.config sur les IIS windows. A la ligne 114 et 115 il faut autoriser les extentions htm et html

Sinon les fichiers template en HTML ne sont pas reconnues …

Voila.


#5

Might want to check the plugins .htaccess file. In mine, I saw this about halfway down:

Allow to serve static files which are safe

<Files ~ “.(test.php|gif|ico|jpg|png|svg|js|css|htm|html|swf|mp3|mp4|wav|ogg|avi)$”>

I changed it to:

Allow to serve static files which are safe

<Files ~ “.(test\php|gif|ico|jpg|png|svg|js|css|htm|html|swf|mp3|mp4|wav|ogg|avi)$”>

(Note the php entry)

Thus solved the 403 error for me without changing permissions.


(Matthieu Aubry) #6

@micrologiciel thanks I’ve fixed it in: Allowing htm+html files in Microsoft web server, to prevent issue; · matomo-org/matomo@9be0bd5 · GitHub


#7

I just tried that little fix there, however I had the little realtime page title images fail to load…

Doing Ray’s permission change solved the problem though, with the “.php” still in the .htacess file.


#8

Came here with the same issue, and the 755 permissions Ray listed worked for me. Thank you!


#9

One reason I never upgrade to the .0 versions… this time I did it even though I knew better. Got the error… found the fix. Thanks Ray.

WDR


(Matthieu Aubry) #10

If you still experience this issue, please try with the latest 2.4.0 beta which is available as per instructions here: I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo

After upgrading to 2.4.0 if you still have the issue please let me know here! We are really hoping to fix this problem for all of you!


#11

@Ebola_Gray

This resolved our issue without needing to change permissions.

[EDIT]

But changing this may result in your icons missing and the PIWIK logo on the upper left error 500.


#12

Directory Permissions Change solutions work for me.
I have tried the other solutions (removing lines by @matt and changing to true by @micrologiciel), but they didn’t work for me.

Thanks to @Ray


#13

@Matt,

I just did as you suggested and upgraded to the 2.4.0b5 beta version. The error is still occurring with no changes.

As background, I have Piwik hosted at webfaction, on a centos6 linux server. After the initial install, I have always upgraded Piwik using the auto links, so I have never had cause to modify any of the permissions of any sub-directories that would be causing this problem.

I think it first appeared after the upgrade to 2.2 or 2.3, but I am not completely sure.

Please let me know how I can help. I’m willing to help out with testing to try and solve the problem.

Thanks,
Russell


#14

Can anyone walk me through how to do this real quick

"Found the fix in an earlier post by DavidY

I fixed the problem by changing the permissions from 750 to 755 of:

/plugins/ZenMode/
/plugins/ZenMode/angularjs/
/plugins/ZenMode/angularjs/quick-access/"


#15

@roy.bragg

Do you have an FTP application?

Or do you have access to your server files from control panel?


#16

@roy.bragg

Either connect to your server via FTP of cPanel/Plesk, whatever suits you.

By going to the each directory and chang the permissions

/plugins/ZenMode/
/plugins/ZenMode/angularjs/
/plugins/ZenMode/angularjs/quick-access/

Thats it. :slight_smile:


(Chris) #17

I did not have this error but after updating to 2.4.0 we got:

Failed to load HTML file: Please check your server configuration. You may want to whitelist “*.html” files from the “plugins” directory. The HTTP status code is 500 for URL “plugins/ZenMode/angularjs/quick-access/quick-access.html”

What now?


(Matthieu Aubry) #18

@Chris could you PM me your piwik uRl, login, password, and also this forum post URL ?


#19

I was having the same problem before AND after the July 2nd update. I update with every single upgrade using the auto upgrade option, since I’m not very tech savvy and whatever. The program seems to work fine with the update (before it lagged on loading stats for referrer sites and outlinks) but that 403 message at the top is pretty annoying, haha.


(Matthieu Aubry) #20

@AnonyMouse could you PM me your piwik uRl, login, password, and also this forum post URL ?

Also we plan to add a new FAQ to explain the various reasons of this problem: Create FAQ to help troubleshoot the error "Failed to load HTML file" · Issue #5404 · matomo-org/matomo · GitHub