Failed to load HTML file: Please check your server configuration. You may want to whitelist "*.html" files from the "plugins" directory. The HTTP status code is 403 for URL "plugins/ZenMode/angularjs/quick-access/quick-access.html"

Same problem here, started when updating to latest 2.3 version a few weeks ago.
Just ran today the 2.4.0 updater, didn’t fix the issue.
Should we fresh re-install 2.4.0 instead of using the upgrade script ?
Keep us posted (and the good work @ Piwik)

Same issue here.
I’ve checked the permissions, they all are on 755 (right from the install, there were no folders with 750).
Then ran through the solution of Ebola_Grey (htaccess entry…).
The only change is that the error message now says “… The HTTP status code is 404…” (not 403 as before).
Besides that, I can’t access the settings page to enable the beta download, because there is no link showing up at the upper right corner.
Any Ideas? This would be very helpful…my customers are getting very impatient because of this. :S

@Matt: My problem is solved I guess. I changed every folder and subfolder of the zenmode plugin to 755 and that`s about it. The Error-Message did not appear again. Thank you all.

Hi Matt & Chris,
chmod to 755 for the folder and subfolder of the zenmode plugin…didn’t work for me.

Didn’t work either :

Allow to serve static files which are safe

<Files ~ “.(test\php|gif|ico|jpg|png|svg|js|css|htm|html|swf|mp3|mp4|wav|ogg|avi)$”>

All my reports are displayed as empty in Piwik interface.

Guess I’ll try a reinstall from scratch of 2.4.0 Piwik files (and let the database untouched).

So avoid update 2.4.0 for a bit?

no solution yet?

Yesterday I did a complete reinstall of piwik, including a full database reset (did a sql backup before).
No changes after reinstallation, the error is still occurring. :frowning:
Again, I’ve tried the solutions as mentioned before. Still no changes and I still can’t access the Settings Panel, which is essential…

Any ideas?

@larsortlepp can you please PM link to this post, and tempoarry access to your Piwik instance? I could check if I see a problem. Otherwise we would like to post a FAQ explaining possible causes as unfortunately there are several possible reasons: Create FAQ to help troubleshoot the error "Failed to load HTML file" · Issue #5404 · matomo-org/matomo · GitHub

In my case Piwik 2.4.0 didn’t show this error message previously, but today it did. One thing I know for shure is that the server has been updated from php 5.3.3-7+squeeze18 to php 5.3.28-1~dotdeb.0 since my previous visit to my Piwik installation.

Does anyone know if this is resolved in version 2.4.1?

Our web server is running PHP: 5.2.17 & MySQL 5.5.37 - Will this be an issue if I upgrade or should I just stick with 2.3.0?

There is one more thread concerning the same issue.,115950

It’s getting close to having it resolved I believe, as these problems seem to be in connection with settings from .htaccess file(s).

Please check out the new FAQ we have added to troubleshoot this issue:

How do I let my web server serve HTML files?