Error widget after updating from 1.4 to 1.5


#1

Hello,
I updated from 1.4 my Piwik to 1.5 using the automatic function.
The installation and the database conversion were OK.

Now I can see this error message “The Piwik configuration file couldn’t be found and you are trying to access a Piwik page.” appearing randomly on some Widgets.

See this print screen : Error Widgets Piwik 1.5

The config.ini.php and global.ini.php files are in the Piwik/config directory and seem to be converted.

How can I, please, fix this problem ?


#2

I got the same error message after upgrading my piwik from 1.4 to 1.5 :frowning:


#3

Hi Romain,

Did you find any solution ?

My problem is NOT solved

Help please !


#4

No, I still have the problem and I don’t know how to solve it !:frowning:


(Matthieu Aubry) #5

That’s really surprising bug… sometimes it works, sometimes it doesn’t?

What is your server configuration, OS, PHP, apache, etc.?


#6

That’s really surprising bug… sometimes it works, sometimes it doesn’t?

No it never works and I have the same error on every site…

What is your server configuration, OS, PHP, apache, etc.?

Debian Lenny, Apache 2.2.9, PHP 5.3.6


#7

I don’t know if it’s the right solution, but it works fine for me. I’ve got the same error as people above after upgrade from 1.4 to 1.5, but I just commented (by adding ; on the beggining of the lines) the lines with


logger_error[] = screen

and


logger_exception[] = screen

and it starts to work correctly. But, as I sad, I don’t know if it’s a “right” sollution…


#8

i have the same problem here after upgrading from 1.4 to 1.5 through the webinterface.

maybe some database conversion that got corrupted?


#9

Any news about our problem ?
Is there a bug on bugtracker ?


#10

Hello,
I get the same bug.
I have reinstalled Piwik from new (including database cleaned) but the error still appears randomly, and all the links are red.
Had not this problem on others websites. All are hosted by ovh.


#11

In found this in error log of the server:
“Premature end of script headers”


#12

Yes , my website is also hosted by ovh !


#13

My website isn’t hosted by OVH :wink:


(JulienM) #14

Same error, hosting is amen.fr.

It is quite random, it is not always the same widget which displays the error :


The Piwik configuration file couldn't be found and you are trying to access a Piwik page.
  » You can install Piwik now
If you installed Piwik before and have some tables in your DB, don't worry, you can reuse the same tables and keep your existing data!

It happened on List of external websites, Visits by server time, List of keywords, Feedburner statistics. Sometimes more than one widget will display the error but never a graph widget.

Everytime though, all links at the top (except for dashboard) becomes orange.

config.ini.php is present in config.

Purging tmp/templates_c (and possibly tmp/assets) DOES solve the issue.

EDIT: The issue came back on my instance some time after, purging the tmp directory does not solve the issue.


#15

I purged all the tmp directory but it didn’t solve the issue !


#16

Purging tmp/templates_c (and possibly tmp/assets) DOES solve the issue.

Didn’t solve it either.


(JulienM) #17

I can confirm as well the error is back on my piwik instance.


(Peterbo) #18

Is there suPHP running on your servers?


#19

No.

I have now updated 4 instances of Piwik. 2 of them are ok, 2 others have this issue.
Those last 2 are the ones I have upgraded the more recently.
Seems that a few widgets are loaded until the process is prematurely stopped.


(vipsoft) #20

Strange indeed. You might want to ask your hosting provider.