Database Upgrade Required after fresh install


#1

Hello,

I’m trying to install Piwik 2.11.2 on a new server.
The installation process goes through all steps but ends with the message in attachment [attachment 2220 upgradeRequired.png] (Database upgrade required) instead of opening the Piwik login page.
If I click on “Continue to piwik”, Chrome complains about a redirection loop.
I’ve executed the SQL queries but I’m still redirected to the “Database upgrade required” page.

This week, I installed this Piwik version successfully on myPC (powered by Xampp) and on a Gandi Cloud Instance … but I fail on this server.
Any idea of what’s going wrong with that server?

Best regards,

Jean-Marc Astesana
PS: Apache/2.2.29 (Unix) PHP/5.5.20 MySQL 5.5.23 (through mysqli extension).


(Matthieu Aubry) #2

Hi there,

unfortunately we haven’t heard of this issue before. it works fine in our tests… no redirect loop. If you have more info about this (or if anyone else experience a problem) please let us know


#3

Hello,

I first thought the problem was the server is in a DMZ and has no Internet connection to check the last version. But we have a deeper problem: Piwik writes nothing in the database!
After talking with our database team, it seems the problem could be that our MySQL instances are not standard, they are configured with autoCommit turned off.
I found no configuration trick about autocommit in Piwik, is there is a way to fix the problem without changing database configuration?

Best regards,

Jean-Marc


(Crescentstar) #4

Hello, I have the same problem, have you slove it?


#5

Yes, I installed an “out of the box” mysql instance (with autocommit turned on).