Dashbord not working after upgrade to 1.5


(XSK8) #1

Hi everybody, after upgrading one of my piwiks I have real strange behaviour in the Piwik.

  1. Dashboard is not showing any widget
    (seems that all ajax supportet stuff is not working)
  2. everything else is extremly slow.

Any idea about that issue?


(Peterbo) #2

Please manually delete all files in the tmp/assets and tmp/templates_c folders.


(XSK8) #3

@mediaproweb: I already did this. Also deleted browser cache.

No change at all… :frowning:

Then I downgraded to 1.4 --> works
Uprgrade again to 1.5 --> same strange behaviour…

Any other ideas?


#4

Same here:
*Update to 1.5 without errors
*php 5.3.2
*shared hosting
tried to delete tmp/ files

firebug shows a http 500 (internal server error) for:
…index.php?module=Proxy&action=getJs&cb=…

Any ideas? :frowning:


(Matthieu Aubry) #5

flix, please look into your webserver error logs. There should be some error there?


#6

Same here,
I’ve done the upgrade today without any error or message. The dashboard is empty and I can’t select even a specific day to be shown. The logs of apache show no error, just simple GET access without error.

Is there any configuration for the AJAX stuff necessary? I agree with XSK8, there must be a relation of the problem with AJAX. Or any other idea?


(Matthieu Aubry) #7

All,

If you use Firebug on Firefox to look at the Net panel > Http requests, do you all see 500 response? or something else?
Then, you should have some errors in the error.log for your apache.
If not, make sure errors are logged, see in php.ini search for “error” & then restart webserver.
Please copy here all errors or other information


#8

Hello everyone,

the problem is simple: Piwik 1.5 needs about 1 MB of JavaScript (uncompressed). It also tries to minimize the load on server side, but that’s a little bit too much for some shared hosting environments.

My current solution: Commenting out line 232


$content = JSMin::minify($content);

in “core/AssetManager.php”. Works like a charm for me. :slight_smile:

To the devs: Please try to reduce the needed JS code. jqPlot is a beast. :smiley:

Best regards,

meNeither


#9

@matt: Error-logging is on in php => no error in log, neither 500 or anything other

@meNeither: Tried your suggestion => same behaviour, nothing on the dashboard etc. Furthermore, I’ve no shared hosting, but a full server and memory should not be the problem (the server is boring with low memory consumption).

What is the difference between 1.4 and 1.5?! 1.4 was working perfectly, 1.5 with same settings not.

Thanks for your feedback so far!
Ralf


#10

I have the same bug and I solve it with


[Debug]
disable_merged_assets = 1

in config.ini.php.


#11

@perabo Did you delete your browser cache and the assets cache (tmp/assets) in Piwik?

@colundrum That’s a better approach than mine. But it’s the global.ini.php. :slight_smile:


#12

Wow, problem solved, but in a different way as you think :):

  • Changing the option of colundrum put me on the right track
  • After changing to value 1 I’ve got an error: The js asset with ‘src’ = libs/jqplot/jqplot.core.js is not readable
  • The reason was that the owner of the directory “libs/jqplot” was root and not wwwrun
  • After changing to wwwrun everything is running again now (with both values, disable_merged_assets = 0 and = 1).

Strange that I didn’t see an error before. However: Thanks to all!!!
Ralf


#13

@perabo Interesting. I tried it as you said, but for me it’s definitely the server load. Different causes, same effect, I guess. Let’s hope this helps others experiencing similar problems. :slight_smile:


(Matthieu Aubry) #14

@perabo Interesting, I created a bug report in: Assets not readable cause asset manager to fail and not display error message · Issue #2498 · matomo-org/matomo · GitHub


#15

[Debug]
disable_merged_assets = 1

works :wink:

I have checked the file permissions and everythings looks fine, so that was not the problem.


(XSK8) #16

[quote=flix]


[Debug]
disable_merged_assets = 1

works for me too! THX!

But will this infuence the next upgrade? To be honest, I did not realy understand what it does… :wink:


#17

[quote=colundrum]
I have the same bug and I solve it with


[Debug]
disable_merged_assets = 1

in config.ini.php.[/quote]

Works here too. I installed Piwik today the first time had exactly the same problems as XSK8.


#18

Hello !

same problem also after 2 days of installation : the dashboard is empty and I can’t select new widget !


#19

[quote=meNeither]
@colundrum That’s a better approach than mine. But it’s the global.ini.php. :)[/quote]

It works in config.ini.php without touch global.ini.php and in the header of global.ini.php :


; If you want to change some of these default values, the best practise is to override
; them in your configuration file in config/config.ini.php. If you directly edit this file,
; you will lose your changes when you upgrade Piwik.


(Matthieu Aubry) #20

What exactly is the error message that you get when looking at the JS/CSS URL ? Is it a memory error, or time out? Maybe we can force Piwik to configure this.