1.2 beta bug reports


(Matthieu Aubry) #1

Hello

UPDATE: see post in: 301 Moved Permanently


#2

If you select date range of today no stats are shown and the display looks like the following.


(Matthieu Aubry) #3

This error seems to be when using Mysqli.
organicspider, what is the error message exactly (can’t see all of it in the screenshot)?


(vipsoft) #4

Unknown column. Sounds like the update script failed for some reason.


#5

It came back and said that it has completed okay. Stats for the previous day showed fine.


#6

I cloned my DB and tried again but this time performed the DB upgrade from the command line. This time is worked fine and statistics for today are visible.


(Elam) #7

I had upgrade to RC1 and then the data was not shown. i am getting this error when i try to access the any API

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘visitor_idcookie’ in ‘field list’

Let me know the workaround for this …

Elam


#8

Had another go at the upgrade. Here are the steps I followed and yes this time it broke.

  1. Moved analytics directory to a .old
  2. Downloaded piwik tar file
  3. Extracted and changed permissions to webuser:webuser
  4. Copied config.ini.php from old config directory to the new one and ensure write bit was set
  5. Went to analytics URL and was told upgrade was required
  6. Upgraded and logged in
  7. Stats are showing like my original screenshot with NaN for the values

The difference this time was that I used the original database and did not clone it to a new name.


(Matthieu Aubry) #9

organicspider, what are all the error messages displayed in Piwik?

Elam, did you see any error during or after the update?
Are you using mysqli?


(Elam) #10

matthieu

I got this error after update . When i go to Referrer or visitors tab , i am getting this error.

I had open the piwik_log_visit table i see some new column for custom variable

in config file it says adapter = “PDO_MYSQL”

Let me know if you any further information

Elam


(Elam) #11

I am getting this error while Archiving also . Have a Look at the log below

Elam

[i]Starting Piwik reports archiving…

Archiving period = day for idsite = 1…

<?xml version="1.0" encoding="utf-8" ?> - Archiving for visitor segment No ... <?xml version="1.0" encoding="utf-8" ?> - Archiving for visitor segment data ... <?xml version="1.0" encoding="utf-8" ?> - Archiving for visitor segment available ... <?xml version="1.0" encoding="utf-8" ?> Archiving period = week for idsite = 1... <?xml version="1.0" encoding="utf-8" ?>[/i]

(Matthieu Aubry) #12

Elam, I think the problem is that you haven’t uploaded files correctly maybe ? the field visitor_idcookie is not used anymore in Piwik. try to reupload all files


(Elam) #13

Thanks matthieu , you had given me the Clue , Actually the Problem is with the third party plugin’s. Currently all the third party plugin use "visitor_idcookie " . it will be good if we inform user to deactivate all the Third party plugin before upgrade it .

and also whether it’s possible to check the plugin when we do the upgrade and inform user about the incompatibility with the current version.

Elam


#14

Hello,

The memory leak still crashes against the php(v5.2.14) limit:

Running the archive.sh process, I alse experience the segment parameter errors reported by Elam. I upgraded Piwik manually, i.e. I saved config.ini.php, deleted the piwik directory, extracted piwik-1.2-rc1.zip and overwrote config.ini.php, then I successfully upgraded the database on command line as recommended for large sites.

As for 3rd-party (!=“By Piwik” is it?) plugins, we use MultiSites only, version same as piwik.

Sorry for not having better news,
HamsterDerwisch


#15

Agreed Elam, only third party plugin I was using was GeoIP. Once I disabled that the error about

Mysqli prepare error: Unknown column 'visitor_idcookie' in 'field list'

went away. Does 1.2.1RC have updated GeoIP data ? Do I still need to use that plugin?


(Elam) #16

organicspider , the 1.2 rc1 will not update the geoip plugin . incase if you want to make it work . just open the geoip.php file and look for “visitor_idcookie” and replace it with “idvisitor” . save it . run the archive again it will work .

Elam


#17

I just upgraded to 1.2 rc1 since I am very interested in the custom variables.

If I select the date-range of week, including today, I see: "There is no data for this report."
However, if I select date-range of day, for today, I see my custom variables showing up - is this a bug?

See the two attached screen shots for details…


(Matthieu Aubry) #18

doman, this is a known bug, see: Period reports must always or never include today's statistics · Issue #5793 · matomo-org/matomo · GitHub

organicspider , I will publish the new GeoIP when we release 1.2 stable, stay tuned


(Matthieu Aubry) #19

OK I just released 1.2-rc2 with few more bug fixes. Please give it a try and report any issue you experience!


(Matthieu Aubry) #20

UPDATE: 1.2-rc3 with all known bugs now fixed. Please let us know if you have any issue. This will become 1.2 official if nobody reports a bug :slight_smile: