0 visites since piwik 1.8!


#1

Hello, I have updated 2 piwik into 1.8, one work, one other (without lock table, but fixed now) have 0 visits since the update.
Can you help me?

Thanks

EDIT: update 1.8.1 not fix


(Matthieu Aubry) #2

Please check the faq: Troubleshooting - Analytics Platform - Matomo


#3

Hello,

And what in particular?
Because it’s an update, worked before then.

Cheer,


(Matthieu Aubry) #4

please check web server error logs ?


#5

No error. I have cron enabled, when the lock activation is done, seam sould wait the cron parsing to see the data.


#6

Hi, please inform me when you have a solution for this one. I have the same problem here: 0 visites after the upgrade…

I’m considering to remove Piwik from all my websites.


#7

Check the right of the mysql account, you need have check all the right for the database except grant, the previous tracking is not lost (just not displayed).


#8

Hi,

Thanks for this info.
Already did that, but still it is not working…
:S


#9

I have need wait lot of time (1 day), and cron to restore all.


(Matthieu Aubry) #10

Please run: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

Then wait 1 day, if you still have the prob please PM me the bug description + piwik url and login so I can see thanks


#11

Thanks Matt,

That would be great!

Cheers,
Robert


#12

Hi,

Started with an archive attempt via a webbrowser, but got quite a few ‘Out of memory’ errors, like:

Fatal error: 1 total errors during this script execution, please investigate and try and fix these errors. First error was: Got invalid response from API request: xxxxxxxxxxxxx/misc/cron/…/…/index.php?module=API&method=VisitsSummary.getVisits&idSite=8&period=year&date=last52&format=php&token_auth=xxxxxxxxx&trigger=archivephp. Response was '
Fatal error: Out of memory (allocated 31719424) (tried to allocate 4104 bytes) in xxxxxxxx/core/Dat in xxxxxxxxxxx/misc/cron/archive.php on line 555

Now I have made a cron job in Direct Admin, running every 5 minutes.

Let’s see what that brings…

Cheers,
Robert


(Matthieu Aubry) #13

your memomry limit is only 32 M too small for piwik often


#14

Hi,

Do you have the GeoIP plugin active?

I had the same problem since 1.8.1

I’ve solved it, by disableing the GeoIP plugin.


#15

I have not this plugin in my case.


#16

Works after a complete new install of 1.8.2

Lost all my data, but I’d rather start with a clean install than lose even more time with this…
:slight_smile:


#17

Hello

I am facing the same issue. After I upgraded the piwik version 1.5.1 to 1.8.1 my return visitors have been going down.
Please take look the chart attached.

Thanks


#18

same problem here


#19

Apperently but not sure right now enabling and removing Do Not Track support in privacy settings seems to make things to work again. Tell me if you’re experiencing the same


(Matthieu Aubry) #20

There are 2 problems discussed in this tread

  1. returning visitors not working well — please report your issue in this thread instead: 301 Moved Permanently

  2. no visit since Piwik 1.8 ---- see this FAQ: Troubleshooting - Analytics Platform - Matomo