Zend error with latest 0.6.2 upgrade


(RChadwick) #1

When I upgrade from 0.6.1 to 0.6.2, I get this error:

( ! ) Fatal error: Class ‘Zend_Registry’ not found in C:\Websites\GibsonTechnologies\piwik\core\Updates.php on line 35
Call Stack

Time Memory Function Location

1 0.0006 325328 {main}( ) …\index.php:0
2 0.7846 2244792 Piwik_FrontController->dispatch( ) …\index.php:59
3 0.8403 2384344 call_user_func_array ( ) …\FrontController.php:126
4 0.8403 2384480 Piwik_CoreUpdater_Controller->index( ) …\FrontController.php:0
5 0.8406 2384648 Piwik_CoreUpdater_Controller->runUpdaterAndExit( ) …\Controller.php:200
6 1.0796 3030896 Piwik_Updater->getSqlQueriesToExecute( ) …\Controller.php:234
7 1.1118 3042472 require_once( ‘C:\Websites\GibsonTechnologies\piwik\core\Updates\0.6.2.php’ ) …\Updater.php:113
8 1.1118 3042688 Piwik_Loader::autoload( ) …\Loader.php:0
9 1.1133 3053352 Piwik_ErrorHandler( ) …\ErrorHandler.php:0

Reinstalling 0.6.1 fixes things. Any ideas?


(ronny) #2

[size=14pt]I have the same problem with 0.6.3
It is urgent! how can I fix it or at least go back to previous version?
[/size]

( ! ) Fatal error: Class ‘Zend_Registry’ not found in C:\Websites\GibsonTechnologies\piwik\core\Updates.php on line 35
Call Stack

Time Memory Function Location

1 0.0006 325328 {main}( ) …\index.php:0
2 0.7846 2244792 Piwik_FrontController->dispatch( ) …\index.php:59
3 0.8403 2384344 call_user_func_array ( ) …\FrontController.php:126
4 0.8403 2384480 Piwik_CoreUpdater_Controller->index( ) …\FrontController.php:0
5 0.8406 2384648 Piwik_CoreUpdater_Controller->runUpdaterAndExit( ) …\Controller.php:200
6 1.0796 3030896 Piwik_Updater->getSqlQueriesToExecute( ) …\Controller.php:234
7 1.1118 3042472 require_once( ‘C:\Websites\GibsonTechnologies\piwik\core\Updates\0.6.2.php’ ) …\Updater.php:113
8 1.1118 3042688 Piwik_Loader::autoload( ) …\Loader.php:0
9 1.1133 3053352 Piwik_ErrorHandler( ) …\ErrorHandler.php:0

Reinstalling 0.6.1 fixes things. Any ideas?
[/quote]


(vipsoft) #3

There is no reference to Zend_Registry in core/Updates.php.

The first thing I’d check is if eAccelerator is present. If so, disable it and restart Apache (if mod_php) or php (if fast cgi).