Zeitspannen ohne Aufzeichnungen


#1

Ich nutze Piwk (aktuelle Version) auf einer Webseit mit 300-600 Besucher pro Tag.

Ich habe in letzter Zeit nicht so oft reingeschaut und jetzt ist mir aufgefallen, dass es immer wieder Zeitpannen gibt, wo nichts aufgezeichnet wird, manchmal z.B. 3 Tage aber auch schon mal 2 Wochen. Die Aufzeichnungen beginnen aber jedes Mal von selbst wieder, ohne dass ich was gemacht hätte.

Hat jemand eine Idee, woran das liegen könnte oder wie ich am besten vorgehe um die Ursachen des Phänomens zu identifizieren.

Danke
Hekla


(Stefan Giehl) #2

Wurden wirklich keine Daten augezeichnet, oder werden nur die Daten nicht archiviert?
Das kannst du am besten über das Besucher-Log nachsehen. Überprüfe ob hier Daten angezeigt werden wenn du einen Zeitraum auswählst in dem sonst “keine Daten” verfügbar sind


#3

Danke für die Nachricht.

Habe mal nachgesehen: Beim Log steht an enstpechenden Tagen "Es stehen keine Daten für diesen Bericht zur Verfügung. "

Zur Verbildlichung meines ersten Posts habe ich noch den “Graph der letzten Besuche” über einen längeren Zeitraum angehängt.


(Stefan Giehl) #4

Du verwendest das Tracking über Javascript-Pixel oder Log-Analyse?


#5

Das ist mein Code:


<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setDocumentTitle", document.domain + "/" + document.title]);
  _paq.push(["setCookieDomain", "*.www.domain.tld"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//stats.domain.tld/";
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    _paq.push(['setSiteId', 1]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="http://stats.domain.tld/piwik.php?idsite=1&rec=1" style="border:0" alt="" /></p></noscript>
<!-- End Piwik Code -->


(Stefan Giehl) #6

Tracking-Code sieht soweit normal aus. Denke nicht dass es daran liegen sollte.
Hast du Zugriff auf die Error-Logs bzw. Access-Logs auf dem Server auf dem Piwik läuft?
Vllt lässt sich in diesen was finden, ob an diesen Tagen überhaupt etwas bei Piwik ankam bzw. Fehler auftraten.


#7

Danke für die Antwort. Jetzt hat es gedauert, bis ich mich wieder damit beschäftigen konnte!

Die Logs sehen normal aus, keine auffälligen Fehler. Auf dem Webspace läuft auch noch Webalizer und der zeigt in den Tagen normales Traffic Aufkommen an …

Inzwischen habe ich die Piwik Installation auf einen anderen Webspace umgezogen – kein Unterschied.
Jetzt importiere ich mal alle Log files und schaue was dann angezeigt wird.

Hat noch jemand eine Idee, woher die leeren Tage stammen könnten …?
[attachment 2383 stats-july-aug.png]