WP-Matomo 1.0.30 error certificate file!


Can’t get any further with this error.

WP-Matomo 1.0.30 was not able to connect to Matomo using your configuration. During connection the following error occured:
error setting certificate file: /etc/ssl/certs/ca-certificates.crt

Matomo Mode: Self-hosted (HTTP API, default):
Matomo URL: https://analytics.example.com
Auth token: xxxxxxxxxxxxxxxxxxx
HTTP connection via: cURL
HTTP method: POST

/etc/ssl/certs/ca-certificates.crt root:root

matomo v4.16.0
Wordpress v6.4.2
WP-Matomo v1.0.30

Hi @domi I hope you’re doing well.
Base on the error you are getting, the issue is related to SSL certificate.
Please double check if there is an SSL installed on the server.
If there is, I would recommend to force SSL by following this guide: https://matomo.org/faq/how-to/faq_91/

The certificate is installed on the server. I checked it.
Plugin ForceSSL was installed and in the config.ini.php force_ssl = 1 was enabled.

The error still persists.