WordPress plugin not working anymore

Dear Community,
until yesterday Matomo was working fine. Suddenly there was a critical error, after several tests, I found it was the matomo plugin. As soon as I deactivate it the site works, once i activate it, the site breaks. I downloaded a fresh version from your site, but still the same. Front page keeps working, BUT backend is white.

Any suggestions?

thank you

Hi @rschildt

Can you detail the error you get?

Kind regards

Mat

Hey Mat,
attached a screenshot of the error:
"There was a critical error on your website. Please check the inbox of your site admin email address for further instructions.

Learn more about troubleshooting WordPress."

Anyone an idea? I have to manually disable all plugins via FTP and rename “plugins” to “1_plugins” and reenable it, than activate all plugins BUT matomo than the site works again

thanks

Hi @rschildt

You should have received an email with the callstack of the error. Can you share it?
Could you also share your php error log and wordpress log files lines related to this issue?
Kind regards

Mat

natürlich !

DEBUG.log

[07-Jun-2022 09:57:52 UTC] PHP Warning:  Attempt to read property "item_id" on int in /kunden/463480_22299/webseiten/wordpress/wp-content/themes/enfold/framework/php/auto-updates/class-pixelentity-theme-update.php on line 93
[07-Jun-2022 09:58:01 UTC] Matomo: Matomo is not yet installed... installing now
[07-Jun-2022 09:58:01 UTC] Matomo: Matomo will now create the database
[07-Jun-2022 09:58:01 UTC] Matomo: Matomo is now creating the config
[07-Jun-2022 09:58:01 UTC] Matomo: Matomo is now syncing blogId 1
[07-Jun-2022 09:58:01 UTC] Matomo: Matomo site is known for blog (2)... will update
[07-Jun-2022 09:58:01 UTC] Matomo: Matomo will now sync 84 users
[07-Jun-2022 09:58:01 UTC] Matomo: Matomo is now installing the tracker
[07-Jun-2022 09:58:01 UTC] Matomo: Matomo will now init the environment
[07-Jun-2022 09:58:01 UTC] Matomo: Matomo will now init the front controller and install plugins etc
[07-Jun-2022 09:58:02 UTC] Matomo: Matomo will now sync 84 users
[07-Jun-2022 09:58:02 UTC] Matomo: Matomo will now trigger an update
[07-Jun-2022 09:58:02 UTC] Matomo: No settings changed yet
[07-Jun-2022 09:58:02 UTC] PHP Fatal error:  Uncaught Error: Undefined constant "FS_CHMOD_FILE" in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php:164
Stack trace:
#0 /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php(86): WP_Filesystem_Direct->chmod()
#1 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(156): WP_Filesystem_Direct->put_contents()
#2 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Installer.php(362): WpMatomo\Updater->update()
#3 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Installer.php(161): WpMatomo\Installer->update_components()
#4 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo.php(229): WpMatomo\Installer->install()
#5 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(307): WpMatomo->init_plugin()
#6 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
#7 /kunden/463480_22299/webseiten/wordpress/wp-includes/plugin.php(476): WP_Hook->do_action()
#8 /kunden/463480_22299/webseiten/wordpress/wp-settings.php(598): do_action()
#9 /kunden/463480_22299/webseiten/wordpress/wp-config.php(108): require_once('...')
#10 /kunden/463480_22299/webseiten/wordpress/wp-load.php(50): require_once('...')
#11 /kunden/463480_22299/webseiten/wordpress/wp-admin/admin.php(34): require_once('...')
#12 /kunden/463480_22299/webseiten/wordpress/wp-admin/plugins.php(10): require_once('...')
#13 {main}
  thrown in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 164
[07-Jun-2022 09:58:58 UTC] Matomo: Scheduled tasks perform update
[07-Jun-2022 09:58:58 UTC] Matomo: No settings changed yet
[07-Jun-2022 09:58:58 UTC] PHP Fatal error:  Uncaught Error: Undefined constant "FS_CHMOD_FILE" in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php:164
Stack trace:
#0 /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php(86): WP_Filesystem_Direct->chmod()
#1 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(156): WP_Filesystem_Direct->put_contents()
#2 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/ScheduledTasks.php(208): WpMatomo\Updater->update()
#3 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(307): WpMatomo\ScheduledTasks->perform_update()
#4 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
#5 /kunden/463480_22299/webseiten/wordpress/wp-includes/plugin.php(524): WP_Hook->do_action()
#6 /kunden/463480_22299/webseiten/wordpress/wp-cron.php(138): do_action_ref_array()
#7 {main}
  thrown in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 164
[07-Jun-2022 10:04:35 UTC] Matomo: No settings changed yet
[07-Jun-2022 10:04:36 UTC] PHP Fatal error:  Uncaught Error: Undefined constant "FS_CHMOD_FILE" in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php:164
Stack trace:
#0 /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php(86): WP_Filesystem_Direct->chmod()
#1 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(156): WP_Filesystem_Direct->put_contents()
#2 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(88): WpMatomo\Updater->update()
#3 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo.php(220): WpMatomo\Updater->update_if_needed()
#4 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(307): WpMatomo->init_plugin()
#5 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
#6 /kunden/463480_22299/webseiten/wordpress/wp-includes/plugin.php(476): WP_Hook->do_action()
#7 /kunden/463480_22299/webseiten/wordpress/wp-settings.php(598): do_action()
#8 /kunden/463480_22299/webseiten/wordpress/wp-config.php(108): require_once('...')
#9 /kunden/463480_22299/webseiten/wordpress/wp-load.php(50): require_once('...')
#10 /kunden/463480_22299/webseiten/wordpress/wp-admin/admin.php(34): require_once('...')
#11 /kunden/463480_22299/webseiten/wordpress/wp-admin/index.php(10): require_once('...')
#12 {main}
  thrown in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 164
[07-Jun-2022 10:05:58 UTC] Matomo: Scheduled tasks update geoip database
[07-Jun-2022 10:05:59 UTC] Matomo: No settings changed yet
[07-Jun-2022 10:05:59 UTC] PHP Fatal error:  Uncaught Error: Undefined constant "FS_CHMOD_FILE" in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php:164
Stack trace:
#0 /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php(86): WP_Filesystem_Direct->chmod()
#1 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(156): WP_Filesystem_Direct->put_contents()
#2 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(88): WpMatomo\Updater->update()
#3 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/ScheduledTasks.php(195): WpMatomo\Updater->update_if_needed()
#4 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/ScheduledTasks.php(249): WpMatomo\ScheduledTasks->check_try_update()
#5 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(305): WpMatomo\ScheduledTasks->sync()
#6 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
#7 /kunden/463480_22299/webseiten/wordpress/wp-includes/plugin.php(524): WP_Hook->do_action()
#8 /kunden/463480_22299/webseiten/wordpress/wp-cron.php(138): do_action_ref_array()
#9 {main}
  thrown in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 164
[07-Jun-2022 10:20:54 UTC] Matomo: No settings changed yet
[07-Jun-2022 10:20:54 UTC] PHP Fatal error:  Uncaught Error: Undefined constant "FS_CHMOD_FILE" in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php:164
Stack trace:
#0 /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php(86): WP_Filesystem_Direct->chmod()
#1 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(156): WP_Filesystem_Direct->put_contents()
#2 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(88): WpMatomo\Updater->update()
#3 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/ScheduledTasks.php(195): WpMatomo\Updater->update_if_needed()
#4 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/ScheduledTasks.php(276): WpMatomo\ScheduledTasks->check_try_update()
#5 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(305): WpMatomo\ScheduledTasks->archive()
#6 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
#7 /kunden/463480_22299/webseiten/wordpress/wp-includes/plugin.php(524): WP_Hook->do_action()
#8 /kunden/463480_22299/webseiten/wordpress/wp-cron.php(138): do_action_ref_array()
#9 {main}
  thrown in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 164
[07-Jun-2022 11:19:06 UTC] Matomo: No settings changed yet
[07-Jun-2022 11:19:06 UTC] PHP Fatal error:  Uncaught Error: Undefined constant "FS_CHMOD_FILE" in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php:164
Stack trace:
#0 /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php(86): WP_Filesystem_Direct->chmod()
#1 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(156): WP_Filesystem_Direct->put_contents()
#2 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(88): WpMatomo\Updater->update()
#3 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/ScheduledTasks.php(195): WpMatomo\Updater->update_if_needed()
#4 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/ScheduledTasks.php(276): WpMatomo\ScheduledTasks->check_try_update()
#5 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(305): WpMatomo\ScheduledTasks->archive()
#6 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
#7 /kunden/463480_22299/webseiten/wordpress/wp-includes/plugin.php(524): WP_Hook->do_action()
#8 /kunden/463480_22299/webseiten/wordpress/wp-cron.php(138): do_action_ref_array()
#9 {main}
  thrown in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 164
[07-Jun-2022 11:24:46 UTC] Matomo: No settings changed yet
[07-Jun-2022 11:24:46 UTC] PHP Fatal error:  Uncaught Error: Undefined constant "FS_CHMOD_FILE" in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php:164
Stack trace:
#0 /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php(86): WP_Filesystem_Direct->chmod()
#1 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(156): WP_Filesystem_Direct->put_contents()
#2 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Updater.php(88): WpMatomo\Updater->update()
#3 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo.php(220): WpMatomo\Updater->update_if_needed()
#4 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(307): WpMatomo->init_plugin()
#5 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
#6 /kunden/463480_22299/webseiten/wordpress/wp-includes/plugin.php(476): WP_Hook->do_action()
#7 /kunden/463480_22299/webseiten/wordpress/wp-settings.php(598): do_action()
#8 /kunden/463480_22299/webseiten/wordpress/wp-config.php(108): require_once('...')
#9 /kunden/463480_22299/webseiten/wordpress/wp-load.php(50): require_once('...')
#10 /kunden/463480_22299/webseiten/wordpress/wp-admin/admin.php(34): require_once('...')
#11 /kunden/463480_22299/webseiten/wordpress/wp-admin/plugins.php(10): require_once('...')
#12 {main}
  thrown in /kunden/463480_22299/webseiten/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 164

EMAIL

Fehler-Details
==============
Ein Fehler vom Typ E_ERROR wurde in der Zeile 407 der Datei /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Db/WordPress.php verursacht. Fehlermeldung: Uncaught Zend_Db_Statement_Exception: WP DB Error: [1146] Table 'db463480.wp_safranmatomo_custom_dimensions' doesn't exist SQL: SELECT * FROM wp_safranmatomo_custom_dimensions WHERE idsite = ? in /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Db/WordPress.php:407
Stack trace:
#0 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Db/WordPress.php(419): Piwik\Db\Adapter\WordPress->after_execute_query()
#1 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/plugins/CustomDimensions/Dao/Configuration.php(104): Piwik\Db\Adapter\WordPress->fetchAll()
#2 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/plugins/CustomDimensions/Dao/Configuration.php(74): Piwik\Plugins\CustomDimensions\Dao\Configuration->fetchAllDimensionsEnriched()
#3 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/plugins/CustomDimensions/CustomDimensions.php(251): Piwik\Plugins\CustomDimensions\Dao\Configuration->getCustomDimensionsForSite()
#4 [internal function]: Piwik\Plugins\CustomDimensions\CustomDimensions->addCustomDimensionsAttributes()
#5 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/core/EventDispatcher.php(141): call_user_func_array()
#6 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/core/Piwik.php(845): Piwik\EventDispatcher->postEvent()
#7 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/core/Tracker/Cache.php(131): Piwik\Piwik::postEvent()
#8 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/core/Access.php(661): Piwik\Tracker\Cache::Piwik\Tracker\{closure}()
#9 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/core/Tracker/Cache.php(135): Piwik\Access::doAsSuperUser()
#10 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/core/Tracker/Cache.php(89): Piwik\Tracker\Cache::updateCacheWebsiteAttributes()
#11 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/core/Tracker/Cache.php(249): Piwik\Tracker\Cache::getCacheWebsiteAttributes()
#12 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/plugins/SitesManager/API.php(771): Piwik\Tracker\Cache::regenerateCacheWebsiteAttributes()
#13 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/plugins/SitesManager/API.php(696): Piwik\Plugins\SitesManager\API->postUpdateWebsite()
#14 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Site/Sync.php(204): Piwik\Plugins\SitesManager\API->addSite()
#15 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/app/core/Access.php(670): WpMatomo\Site\Sync->WpMatomo\Site\{closure}()
#16 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Site/Sync.php(215): Piwik\Access::doAsSuperUser()
#17 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Site/Sync.php(129): WpMatomo\Site\Sync->sync_site()
#18 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Installer.php(294): WpMatomo\Site\Sync->sync_current_site()
#19 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo/Installer.php(127): WpMatomo\Installer->create_website()
#20 /kunden/463480_22299/webseiten/wordpress/wp-content/plugins/matomo/classes/WpMatomo.php(229): WpMatomo\Installer->install()
#21 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(307): WpMatomo->init_plugin()
#22 /kunden/463480_22299/webseiten/wordpress/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
#23 /kunden/463480_22299/webseiten/wordpress/wp-includes/plugin.php(476): WP_Hook->do_action()
#24 /kunden/463480_22299/webseiten/wordpress/wp-settings.php(598): do_action()
#25 /kunden/463480_22299/webseiten/wordpress/wp-config.php(99): require_once('...')
#26 /kunden/463480_22299/webseiten/wordpress/wp-load.php(50): require_once('...')
#27 /kunden/463480_22299/webseiten/wordpress/wp-admin/admin.php(34): require_once('...')
#28 /kunden/463480_22299/webseiten/wordpress/wp-admin/plugins.php(10): require_once('...')
#29 {main}
 thrown

I hope, this helps

Hi @rschildt

It appears that you have one table missing.
You could try to remove the file ./wp-content/uploads/matomo/config/config.ini.php to relaunch the setup process.
Let me know if this solves your issue.

You have also another fatal error which is not related to matomo. You could fix it by adding in your wp-config.php file the following content:

if (!defined('FS_CHMOD_FILE')) {
define('FS_CHMOD_FILE', '0664');
}

Kind regards

Mat

Thank you Mat,
however, when i add the text to wp_config I get a HTTP 300 Error

will try the matomo.

i took over the website for a client, developer messed the site up so badly

Hi @rschildt

You get a 300 error or a 500 error?

Mat