WordPress Install Error - Out of Memory, Even at 1GB RAM Allocated

New to trying Matomo. Does the WordPress plugin work or is it better to use the self-install version?

We have a WordPress Multisite installation. I added the Matomo plugin, but when I tried to activate it (whether doing a network or single-site activate) we get a fatal error with the plugin trying to allocate memory.

We originally had our config set to use 512MB of RAM for WordPress. We changed it to 1GB and Matomo still fails when I try and activate it.

Has anyone gotten this working?

Based on the information you’ve provided, it sounds like the issue you’re facing is a memory allocation issue with PHP, not just WordPress. Matomo requires a PHP memory limit of at least 512M to function properly​.

You mentioned that you’ve already allocated 1GB of RAM for WordPress, but it’s important to note that this is separate from the memory allocation for PHP, which Matomo also relies on. You might need to increase your PHP memory limit to a higher value in your php.ini file, even if you’ve already increased your WordPress memory limit.

Here’s the line you’d need to modify or add in your php.ini file:

memory_limit = 1024M

You might need to increase it to a higher value like 2048M depending on the size and complexity of your site. After changing this setting, don’t forget to restart your web server to apply the changes.

If you’re not sure where your php.ini file is located, you can create a test.php file with the following code, and then open it in a web browser:

<?php phpinfo(); ?>

This will display a page with a lot of information about your PHP configuration, including the location of the php.ini file.

More infos: https://matomo.org/faq/on-premise/how-to-set-up-auto-archiving-of-your-reports/#increase-php-memory-limit


Increase your memory limit to get rid of this error :blush: