WordPress error with WP-Piwik plugin - adminsettings.php not found

Hi, I’m getting an adminsettings.php not found when trying to use the WP-Piwik plugin.
I’ve posted about it at
but have not received any replies.

The error is:
Not Found
The requested URL /wp-admin/settings.php was not found on this server.

I’m using MultiSite, but I tried from both the Network admin and an individual site.
Also, the dashboard says the plugin is Network Enabled with no toggles.

I’d like to only use it for certain sites.


Anyone have any ideas?

I’m still getting this error, even after upgrading WP and all plugins.

What does the log say?

Hi, here’s the apache error log message from when I try from the main dashboard plugin page and click ‘settings’ for wp-piwik:

[Tue Sep 27 20:24:51.941314 2016] [:error] [pid 22023] [client] script ‘/var/www/html/wordpress-generic/wp-admin/settings.php’ not found or unable to stat, referer: http://foo.bar.net/wp-admin/plugins.php


Does that file exist in the location specified? And does the web server user (eg. Apache) have access? ie. Is it readable?

Hi, not only does it not exist in wp-admin, but it does not exist in a clean WP installation (4.6.1 nor 4.5.3).

There is a file named settings.php in wp-admin/network/
Perhaps that is what it should be calling?


I would try that url and see what happens. Who knows?

Hi, I’m not sure what you mean by “try the url”… it needs to be called from within the plugin code.

I don’t have a dev system I can try modifying the plugin on right now.

Is this plugin compatible with WP Multi-Site?


So, something is wrong in your configuration. It is requiring something at a specific location but the file is in a different location. Make sure your web server path(s) are set up correctly.

I don’t know about compatibility.

Hi, apache has the WP install correctly set as Document Root.
Everything else is working (WP, themes, other plugins).


Where is the “Piwik” directory?

Actually, hang on a minute. AFAIK Piwik doesn’t have a “settings.php” file. It has an index.php and a piwik.php file. Are you sure this is a Piwik error and not a WP error?

It’s a WordPress error when I try to go to the setttings page for the WP-Piwik plugin.

Piwik is on a separate server (and working), but I haven’t been able to get to the plugin settings to set up the connection.

The reason I ask is, if you look at the plugins.php file (At WP Git Hub) there is no reference to “settings.php” so how could this file be the referer? Do you have the latest WP install?

Hi, I updated WP to 4.6.1 last weekend (previously was on 4.5.3 with the same error)

Has anyone else tried the plugin lately? Is it working for others?