Windows Server 2008 R2 upgrade from 1.1 to 2.0 failed


#1

Hi,

I had piwik 1.1 working fine for over a year on my Windows Server 2008 R2 VPS.
php version 5.2.11
mysql 5.1

I got the piwik email “Piwik 2.0 - Monumental Release - Why you should use it in 2014!” and decided to upgrade using the “one click” option. All seemed to go well except for a prompt to delete the libs/smarty directory…but then 500 server error and localhosty/piwik is totally unavailable.
Like an idiot I trusted the “one click” upgrade and didn’t back up first (i know … I know…)

Now my piwik is dead in the water. Any assistance/suggestions would be most welcome.


#2

can you ugrade php to 5.3.3? others on 5.2.x seem to have had alot of issues.


#3

According to PHP Manager the current version of php is 5.3.13

although from the command line…
CMD> php -v
…I get an error message “The program can’t start because MSVCR71.dll is missing from your computer”,
…when I click "ok"
PHP 5.2.11 appears in the command line results.

…in the php53_errors.log i get the following:

[31-Dec-2013 11:00:35 UTC] PHP Fatal error: Interface ‘Piwik\View\ViewInterface’ not found in C:\inetpub\wwwroot\piwik\core\View.php on line 110
[31-Dec-2013 11:04:01 UTC] PHP Fatal error: Call to a member function rewriteAssetsPathToTheme() on a non-object in C:\inetpub\wwwroot\piwik\core\AssetManager\UIAssetMerger.php on line 181
[31-Dec-2013 11:12:34 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php on line 108
[31-Dec-2013 11:12:34 UTC] PHP Fatal error: Class ‘\Piwik\Plugins\CorePluginsAdmin\Controller’ not found in C:\inetpub\wwwroot\piwik\core\FrontController.php on line 179
[31-Dec-2013 11:13:37 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php on line 108
[31-Dec-2013 11:13:37 UTC] PHP Fatal error: Class ‘\Piwik\Plugins\CorePluginsAdmin\Controller’ not found in C:\inetpub\wwwroot\piwik\core\FrontController.php on line 179
[31-Dec-2013 11:15:38 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php on line 108
[31-Dec-2013 11:15:38 UTC] PHP Fatal error: Class ‘\Piwik\Plugins\CorePluginsAdmin\Controller’ not found in C:\inetpub\wwwroot\piwik\core\FrontController.php on line 179
[31-Dec-2013 11:18:40 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php on line 108
[31-Dec-2013 11:18:40 UTC] PHP Fatal error: Class ‘\Piwik\Plugins\CorePluginsAdmin\Controller’ not found in C:\inetpub\wwwroot\piwik\core\FrontController.php on line 179
[31-Dec-2013 11:23:37 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php on line 108
[31-Dec-2013 11:23:37 UTC] PHP Fatal error: Class ‘\Piwik\Plugins\CorePluginsAdmin\Controller’ not found in C:\inetpub\wwwroot\piwik\core\FrontController.php on line 179
[31-Dec-2013 11:32:28 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php on line 108
[31-Dec-2013 11:41:18 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php on line 108
[31-Dec-2013 11:44:18 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php on line 108
[31-Dec-2013 11:47:54 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php on line 108
[31-Dec-2013 15:48:57 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php on line 108
[31-Dec-2013 15:50:12 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php on line 108


#4

can you increase the memory of your php.ini to see if it helps try around 512 mega if possible. more than enough in most cases


#5

Thank you so much for your help. Much appreciated!

The only memory value I could find was in global.ini.php in config folder. It was set to 128 so I increased it to 512 and saved.

; Minimum adviced memory limit in php.ini file (see memory_limit value)
minimum_memory_limit = 512

I then attempted to run http://localhost/piwik again on my server. It spun it’s wheels for a while then I got:

A fatal error occurred

The following error just broke Piwik (v2.0.2):
Maximum execution time of 300 seconds exceeded
in C:\inetpub\wwwroot\piwik\libs\Zend\Db\Statement\Pdo.php line 228

If this error continues to happen, there is a good chance to fix this issue by disabling one or more of the Third-Party plugins. You can enable them again in the Plugins or Themes page under settings at any time.

If this error still occurs after disabling all plugins, you might want to consider uninstalling some plugins. Keep in mind: The plugin will be completely removed from your platform.

ExampleFeedburner uninstall
SecurityInfo uninstall
VisitorGenerator uninstall

We appreciate if you send the error report to the Piwik team.
<<<


#6

Try to increase max_execution_time in global.ini.php

Rich


#7

Thanks for the reply Rich…

There is no max_execution_time in global.ini.php or any of the other ini files that I could find…or anything resembling that parameter.
I don’t know php programming at all, but the execution time does not appear to be hard coded in Pdo.php.


#8

http://piwik.org/faq/troubleshooting/#faq_135

maybe this can help?

http://forum.piwik.org/read.php?2,104677

here is a related and similar issue.


#9

Based on the above please try adding the line:

max_execution_time = 600

directly below minimum_memory_limit would do, it’ll just override the default php setting.

Rich


#10

Rich,

Thank you for the suggestion. I added the line: max_execution_time = 600
…where you recommended.
Unfortunately the result was the same.
All third party plugins have been uninstalled.

Thanks anyway :frowning:

A fatal error occurred

The following error just broke Piwik (v2.0.2):
Maximum execution time of 300 seconds exceeded
in C:\inetpub\wwwroot\piwik\core\DataTable\Manager.php line 88

If this error continues to happen, there is a good chance to fix this issue by disabling one or more of the Third-Party plugins. You can enable them again in the Plugins or Themes page under settings at any time.
<<<


#11

The combination of the max_execution_time parameter change plus a restart seems to have worked!
Piwik is working again.

Thank you very much (lesjokolat & rpharrison) for your help and suggestions. Very much appreciated.

Happy New Year