Will there be an piwik update without problems?


(tiw) #1

Hello.
Every update brings new errors and problems :frowning:

After the autoupdate on 0.6 i get the (german) errormessage:

Warning: require_once(LiveOverView/API.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: Datei oder Verzeichnis nicht gefunden in /kunden/xxx/xxx/piwik/plugins/LiveOverView/Controller.php  on line 2

and than

Backtrace -->
#0 Piwik_ErrorHandler(2, require_once(LiveOverView/API.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: Datei oder Verzeichnis nicht gefunden, /kunden/kunden/xxx/xxx/piwik/plugins/LiveOverView/Controller.php, 2, Array ([module] => LiveOverView,[action] => usersOfLast1000,[parameters] => Array (),[defaultModule] => CoreHome,[controllerClassName] => Piwik_LiveOverView_Controller,[moduleController] => /kunden/kunden/xxx/xxx/piwik/plugins/LiveOverView/Controller.php)) called at [(null):0]
#1 require_once() called at [/kunden/kunden/xxx/xxx/piwik/plugins/LiveOverView/Controller.php:2]
#2 require_once([/kunden/kunden/xxx/xxx/piwik/plugins/LiveOverView/Controller.php) called at [/kunden/kunden/xxx/xxx/piwik/core/FrontController.php:115]
#3 Piwik_FrontController->dispatch() called at [/kunden/kunden/xxx/xxx/piwik/index.php:59]

and further

Fatal error: require_once() [function.require]: Failed opening required 'LiveOverView/API.php' (include_path='.:/usr/local/lib/php') in /kunden/kunden/xxx/xxx/piwik/plugins/LiveOverView/Controller.php on line 2

Where is the problem?
What can i do?

Thanks and regards!


(Matthieu Aubry) #2

http://piwik.org/faq/troubleshooting/#faq_44


(tiw) #3

The link doesn’t help.
But the update on 0.6.1 does. There were also a few errormassages but i could fix it…
I hope it will be easier to update piwik in future.