Wie kann ich mehr als 50 Datensätze auslesen? Limit=


#1

Hallo,

Wie kann ich mehr als 50 Datensätze auslesen? Egal was ich bei limit= angebe, es sind immer maximal 50 Datensätze.

Was muss ich machen damit ich alle Datensätze bekomme

/index.php?module=API&method=Live.getLastVisitsDetails&idSite=1&period=day&date=2011-04-04&limit=1000&format=html&token_auth=

Danke

Martin


#2

Hallo,

Hab das selbe Problem,

Kann uns wer weiterhelfen? :wink:

mfg Flatcher


#3

Hmm, irgendwas war da. Ich müsste nur wissen was :wink:

In der “global.ini.php” (Ordner “piwik/config/”) gibt es sonst noch die Option “API_datatable_default_limit = 50”. Die könnte man testweise mal hochsetzen. Wobei der Parameter “limit” diese Option auf jedem Fall aufheben sollte, wenn er höher als 50 ist.

Ansonsten probiert bei Limit mal “-1”.


#4

Limti mit “-1” funktioniert nicht!

Das Umstellen in der “global.ini.php” auf 200 (“API_datatable_default_limit = 200”) hat keinen Effekt.
Es werden immer max. 50 Datensätze angezeigt.

Zur Info: Die “API_datatable_default_limit = 10” war bei mir auf 10, und trotzdem konnte ich die 50 auslesen.

Bitte um Hilfe!


#5

“api_datatable_default_limit” ist ja auch eigentlich dazu da, ein Limit zu setzen, wenn sonst keins angeben wurde.

Der Fehler wundert mich in der Tat etwas. Ich nutze die Api sehr intensiv und wüsste spontan nicht, dass ich irgendetwas geändert habe. Welche Piwik Version nutzt du denn?


#6

Ich verwende Piwik Version 1.2.1
Was funktioniert ist wenn ich limit=15 setzte, das genau 15 Datensätze aufgelistet werden


#7

Hallo,

Ich arbeite mit der selben Version und hab auch das selbe Problem.
Hab deine Tipps schon versucht, nur leider ohne Erfolg. :frowning:

mfg


#8

Ah, ich glaub da war was. Versuche mal statt dem Parameter “&limit=xxx” “&filter_limit=xxx”.


#9

Bin ich wieder eingeschränkt auf 20 Datensätze.


#10

Hmm, letzte Idee. Hast du mal unterschiedliche Formate ausprobiert? Wobei eine Begrenzung von 50 für z.B. XML auch etwas wenig wäre.


#11

Hab csv, tsv, xml und html probiert - mit filter_limit hab ich überall 20 Sätze.


#12

hab den Tipp von Thomas (schönen Dank) bekommen einfach folgendes hinten dranzuhängen: &format=xml&filter_limit=100

also

/index.php?module=API&method=Live.getLastVisitsDetails&idSite=1&period=day&date=2011-04-04&limit=1000&format=html&token_auth=xxx&format=xml&filter_limit=100

Es funktioniert !!!

Weitere Frage: kanns ich für date=2011-04-04 auf ein von Datum bis Datum verwenden?

Danke

Martin


#13

“filter_limit” hab ich weiter oben kurz genannt. Ich glaub das es da einen Fehler in der Dokumentation der aktuellen Version gibt. Im aktuellen RC-Release wurde dies nämlich von “limit” in “filter_limit” geändert.

Einen Datumsbereich gibt es ja erst seit dem aktuellen RC. Ich gehe davon aus, dass dieser bis zur finalen Version auch in der API als Funktion umgesetzt wird. Allerdings geht es ja auch nicht um so viele Daten. Da kannst du das Begrenzen der Daten ja durchführen, nachdem du dir alle Daten gezogen hast.


#14

Also darauf wäre ich persönlich nie gekommen, die selben attribute ganz hinten nochmal hinzuschreiben…


#15

also

/index.php?module=API&method=Live.getLastVisitsDetails&idSite=1&period=day&date=2011-04-04&limit=1000&format=html&token_auth=xxx&format=xml&filter_limit=100


Hallo Martin,
in welche Datei wird das denn eingetragen und wo finde ich die?
Die “global.ini.php” ist es wohl nicht

Grüße Frapero

Weiß niemand die Antwort?