Weird output from archive.sh


(joey001) #1

Since a few weeks, when I trigger

sh /srv/www/vhosts/xyz.com/httpdocs/piwik/misc/cron/archive.sh > /dev/null
it takes ages processing the archive and I get strange outputs like this one:

H)Ã÷¥Ãöâ
þ)ùaJÃâdÃÃ@øNÂÂOÃ`Ãdphw),[908] => Array ([0] => 103,[1] => 1,[2] => 2011-05-27,[3] => 2011-05-27,[4] => 1,[5] => 2011-05-27 21:27:36,[6] => Actions_actions_url_1549,[7] => xÂMÂÃNÃ0
ÂÃ%wÂ&eLsN¸MÂ8F.³:ÂÃÂ
&Â¥ÂiïNÂISvüY¿íÃ
Â{³õÃúGL¸Ã&

Whats going wrong?

Thx,
Joe


(Matthieu Aubry) #2

Are you using latest version of Piwik?


(joey001) #3

Yes , 1.4.


(Matthieu Aubry) #4

What is the full output? can you please put in pastebin.com or something?


(joey001) #5

Unable to post the full shell-output. It runs down my screen for about half a hour like in ‘Matrix’. Very spacey…


(vipsoft) #6

Check your shell’s terminal encoding.


(joey001) #7

Can´t be the encoding. Didn´t change it, and the same happens on three different PCs…

I managed to copy a liitle bit of the output from Putty:
http://pastebin.com/MMYMcRuZ
I already tried to delete the archives and start a rebuild, doesn´t help.

I forgot to mention one thing: Recently Piwik tried to send me a 2.5gigabyte mail:
This is the beginning of that mail, had to delete it from the server.
http://pastebin.com/Efu2rnCv

Greetings,
Joe


(vipsoft) #8

Piwik couldn’t create the csv file for batch insertion.

turn off safe mode or fix the directory/file ownership privs in tmp/assets


(Matthieu Aubry) #9

Thanks for the report. At least, in the next version, the error message will be a lot smaller if there is a problem, making it easier to see the message.


(joey001) #10

Thx for the help, will try that!

Greetings,
Joe


#11

Dear all,

i’m actually facing a similar problem since the update to Piwik 1.4.

I was also using the cron job, but the shell script call with the cron job puts out around 8-10MB of data. As Plesk is sending an eMail every time a cronjob is done, i was receiving all this rubbish output as a 10MB eMail every 30 minutes.

I needed to deactivate the cronjob … any suggestions for a hotfix of this are highly appreciated.

Thanks,
Marco

EDIT: I traced the output in a text file and also found the error message: The last Plesk update seems to have activated the safe_mode in the php.ini. After changing it to “off”, the problem is gone. Thanks for the hints!


(joey001) #12

Update:

Thx for the help, archiving process works fine now!

Joe