Webanalys deaktivieren - Tracking off


#1

Hallo zusammen,

vielen Dank für die Aufnahme im Forum.

Ich muss auch gleich zum Punkt kommen, ob sich einer mit der Funktion unter Einstellungen - Benutzereinstellungen und “Ihre Besuche von der Erfassung via Cookie ausschließen” auskennt.

Dieser iFrame wurde von mir via TYPO3 in eine Website integriert, kann jedoch leider nicht in Firefox und Chrome aufegrufen werden. Komischerweise funktionieren aber IE und Safari (Die sich da sonst ja immer quer stellen).

Es wurde schon an unterschiedlichsten APS´s getestet.

anbei der Link zur Seite um die es geht (ganz unten)

http://www.riemser.com/impressum/datenschutz/

vielen Dank im voraus


(Stefan Giehl) #2

Also bei mir geht das in allen Browsern nicht. Beim Aufruf der OptOut-URL kommt ein 500er. Möglich dass du in den Browsern in denen es bei dir funktioniert zeitgleich in Piwik eingeloggt warst?

Verwendet ihr irgendwelche zusätzlichen Login-Plugins: LDAP, HTTPAuth o.ä.?


#3

Hallo danke für die Antwort,

Es geht mir auch nicht um die URL selber, sondern dass mir diese erst garnicht angezeigt wird. Mit dem Firebug sehe ich dann das er zwar einen iFrame einbindet, jedoch wird der nicht dargestellt.

Ich kann keiner der genannten Plugins erkennen, dass diese installiert sind.

Und nein, ich hatte Piwik lediglich im Firefox geöffnet und da funktionierte es nicht… IE und Safari funktionert.

Via iPhone wird es auch nicht angezeigt…

—> Hatte gestern noch eine ZEile entfernt bzw. hinzugefügt, deswgn der Fehler 500, das hatt eich hier im Forum gefunden: Fixes #6128, fix opt-out iframe error (do not use renderTemplate sinc… · matomo-org/piwik@cfa9f96 · GitHub

/**
* Shows the “Track Visits” checkbox.
*/
public function optOut()
{
$trackVisits = !Piwik_Tracker_IgnoreCookie::isIgnoreCookieFound();

	$nonce = Piwik_Common::getRequestVar('nonce', false);
	$language = Piwik_Common::getRequestVar('language', '');
	if($nonce !== false && Piwik_Nonce::verifyNonce('Piwik_OptOut', $nonce))
	{
		Piwik_Nonce::discardNonce('Piwik_OptOut');
		Piwik_Tracker_IgnoreCookie::setIgnoreCookie();
		$trackVisits = !$trackVisits;
	}

	$view = Piwik_View::factory('optOut');
//Ausgeblendet :
	// $view->trackVisits = $trackVisits;
	// $view->nonce = Piwik_Nonce::getNonce('Piwik_OptOut', 3600);
	// $view->language = Piwik_LanguagesManager_API::getInstance()->isLanguageAvailable($language)
		// ? $language
		// : Piwik_LanguagesManager::getLanguageCodeForCurrentUser();
	// echo $view->render();

//neueingebunden bis Zeile 188

$view = new View("@CoreAdminHome/optOut");

#$view->trackVisits = $trackVisits;
#$view->nonce = Nonce::getNonce(‘Piwik_OptOut’, 3600);
#$view->language = $lang;

return $view->render();

}

#4

Ich vermute mal, dass da bei den Servereinstellungen zu piwik.#deineDomain#.de etwas eingestellt ist, durch dass sich dein Piwik nicht im Frame öffnen lässt. Wenn ich da testweise “http: / / www.piwik.org” rein, dann ist auch Inhalt im Frame.
(Mit google.de bleibt das iframe auch leer.)


#5

Hallo hausa0014,

hast Du mittlerweile das Problem lösen können? Auch ich habe das iframe in Typo3 eingebunden und bekomme sowohl im FF als auch im Chrome nichts zu sehen. IE funktioniert mit einer Warnmeldung.

Danke

Robert