Web host not supporting PHP 5.3.2


#1

I have in the past used Piwik 1.12 for my company web site. I decided to try out Piwik 2.0.3. It didn’t work. I received the following error when starting Piwik at the web site folder location ‘/public/www/analytics’ on the web site domain:

‘Parse error: syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or ‘(’ in /web/sites/_g/_a/_l/websitename.co.uk/public/www/analytics/index.php on line 11’

It seems the requirements are PHP 5.3.2 and MySQL 4.1. My web host I just found out supports MySQL 5.0.51a (which is fine) but only PHP 5.2.4. When I queried my web host about the PHP version, they replied ‘…I know that the reason we use the current version is being it is the most editable version of PHP. It still has the updates from the latest version as we patch this to meet the ever changing requirements.’

Is there any way I can tweak Piwik 2.0.3 to work in this environment please, given the web host reckoned the PHP contains ‘updates’? Otherwise r should I simply reinstall 1.12 and stick with this version until I change web hosts I guess. I can’t seem to download it but I did save a back up of the folder from previously which I can use.

Many thanks!


(Matthieu Aubry) #2

Try 2.1 RC which will give you a useful error message: 301 Moved Permanently


#3

Thanks. I installed Piwik 2.1 RC in separate folder, and running it, received the following error message:

'To run Piwik you need at least PHP version 5.3.2

Unfortunately it seems your webserver is using PHP version 5.2.4-99claranet4.

Please try to update your PHP version, Piwik is really worth it! Nowadays most web hosts support PHP 5.3.2.

Also see the FAQ: My Web host supports PHP4 by default. How can I enable PHP5?’

My web host responded and told me that basically I needed to upgrade to Dedicated IP and then I could run whatever version of PHP I wanted. But they are expensive enough as it is (not very competitive).

‘As the underlying version of our PHP on the shared hosting platform is
version 5.2.4 then any software/cms that you install onto our shared
platform would need to be compatible with version 5.2.4. Unfortunately, as the shared hosting platform is currently used by over
72,000 hosting packages, any PHP upgrades must have fully passed all
testing phases and must have no negative impact in regards to
compatibility for current customers that are using the platform,
however, this is something that is being investigated but no ETA has
been set. As you are looking to utilise a newer version of PHP their is the
option of using your own virtual/dedicated server that we offer. We
install only the operating system and the chosen control panel
interface and then the server is completely your own to install any
versions that you require and may be more suitable for you.’

I saw on the installatoin FAQs that there may be some workarounds but I will check with the web host to see if they are possible or not. However they seem to be for enabling PHP 5 from v4, rather than 5.3.2 or greater.

http://piwik.org/faq/how-to-install/#faq_77


#4

I tried the .htaccess ‘enable php v5’ workarounds and they didn’t work, which the web host afterwards confirmed wouldn’t have worked.

So I’m guessing it’s pretty much game over with this particular web host then regarding Piwik v2?


(Matthieu Aubry) #5

If your host is still using PHP 5.2 and won’t let you upgrade to 5.3, please consider changing host. They live in the past and this is worrying for a web host I think. cheers!


#6

Thanks, yeah that’s pretty much what I thought. My other hosts offer the option to upgrade to 5.3.


#7

I’m confused.
My hosting supports 5.3.10-1ubuntu3.11

But Piwik admin reports:
“The PHP version 5.3 you are using has reached its End of Life (EOL). You are strongly urged to upgrade to a current version…”

What do I need to make Piwik work after may 2015?

JohN


(Matthieu Napoli) #8

JohnG please create another discussion thread, this topic is a year old and that results in sending email notifications to a bunch of people who probably don’t want them.


#9

You’re right, I am sorry.