Web Cron for Auto-Archiving: Error 403


#1

Hello

I use the web cron for auto-archiving. I have no other possibility because I can’t use normal cron jobs on my public server. It still worked after the update to version 2.0.2 but not since 1th january 2014. The error 403 appears after the year changed and I have no idea why. I have checked the Apache log files and they say that but nothing more.

I haven’t changed anything on the server nor my hosting provider.

Do you have any idea what’s going wrong and what I can do?

Thank you for your help.


#2

Hello again

I found the error on my own.

The file GeoIPCity.dat was update at 2014-01-01 00:NN:NN and the file .htaccess was written into the folder /misc

With this file the web cron doesn’t run anymore. I deleted the content of this file. Now everything is OK.

Am I the only one with this problem?


(Matthieu Aubry) #3

It works for us, but maybe there is a bug in Piwik. I’d like to know what caused the bug for you so we can prevent it on other users.

Did you delete the content of the htaccess file, and then it started to work?


#4

Yes, that was all. I deleted the content because I hope that the file wont be created again.

I checked the code of GeoIPAutoUpdater.php updating the GeoIP databases but I don’t found the piece that is responsable for it. Maybe I don’t found it, maybe its everywhere else…


(Matthieu Aubry) #5

Do you mean you deleted the content of the .htaccess file and it fixed the issue ?

Did you also change the content of GeoIPCity.dat ?


#6

Sorry, my answer wasn’t clear enough.

Yes, I delete the content of the .htaccess. No, I don’t change other files like GeoIPCity.dat.


(Matthieu Aubry) #7

Thanks for the report, I created a ticket: htaccess rule causing geoip file to be 403 unloadable · Issue #4508 · matomo-org/matomo · GitHub