Warnings after upgrade


(dazza) #1

hi ive just upgraded my linux server to all the latest up date and with php 7.3.4

but now im getting 2 errors

1 is
LOAD DATA INFILE
Using LOAD DATA INFILE will greatly speed Matomo’s archiving process up. To make it available to Matomo, try updating your PHP & MySQL software and make sure your database user has the FILE privilege.
If your Matomo server tracks high traffic websites (eg. > 100,000 pages per month), we recommend to try fix this problem.

2 is

It is recommended to configure a ‘max_allowed_packet’ size in your MySQL database of at least 64MB. Configured is currently 16MB.

but with this one ive up it to 64mb off ram i dont not the max shude i up it ive got 12gb off ram?


(Lukas Winkler) #2

Hi,

Those are not errors, but warnings:

Your MySQL server doesn’t allow the Matomo users to use the LOAD DATA INFILE feature. This is no problem, but Matomo could do the archivng quicker if you would allow it.

The same here. Changing your max_allowed_packet MySQL config to 64MB might avoid some database issues where Matomo can’t connect correctly to MySQL.


(dazza) #3

so on this one i dint haver this be for so is there a way to fix it?

and this one
Your MySQL server doesn’t allow the Matomo users to use the LOAD DATA INFILE feature. This is no problem, but Matomo could do the archivng quicker if you would allow it.

i did set up archivng ?


(Lukas Winkler) #4

I don’t know your server setup, so you should ask someone more familiar with how the server is configured.

You could enable it as explained here, but there might be a reason why it is disabled:


(dazza) #5

ok i will try and work that one out ?

and what shud i do about this one

It is recommended to configure a ‘max_allowed_packet’ size in your MySQL database of at least 64MB. Configured is currently 16MB.


(Lukas Winkler) #6

The same as above. Make sure if there is a reason for this config and if not, change it:


(Fabian Dellwing) #7

Open /etc/mysql/mysql.conf.d/mysqld.cnf and look for the line max_allowed_packet = 16M change it to 64M. Restart your mysql server.


(dazza) #8

ok if i do it and it dont work do u mind if i come back on here and ask?


(dazza) #9

ok ive set it ive got mariadb my sql so the path was different

sudo nano /etc/mysql/mariadb.conf.d/50-server.cnf

but i put 64m in and it still saying

It is recommended to configure a ‘max_allowed_packet’ size in your MySQL database of at least 64MB. Configured is currently 16MB.


(dazza) #10

[quote=“fdellwing, post:7, topic:32876”]hi
max_allowed_packet = 16M
[/quote]

hi ive just sorted it thank guys