Warning: array_combine() expects parameter 1 to be array, null given in /var/www/piwik.c6-berlin.com/plugins/BotTracker/API.php on line 88


#1

There is an error. Please report the message (Piwik 2.2.2) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Warning: array_combine() expects parameter 1 to be array, null given in /var/www/piwik.c6-berlin.com/plugins/BotTracker/API.php on line 88

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [:]
#1 array_combine(…) called at [/var/www/piwik.c6-berlin.com/plugins/BotTracker/API.php:88]
#2 Piwik\Plugins\BotTracker\API->getAllBotDataPie(…) called at [:]
#3 call_user_func_array(…) called at [/var/www/piwik.c6-berlin.com/core/API/Proxy.php:209]
#4 Piwik\API\Proxy->call(…) called at [/var/www/piwik.c6-berlin.com/core/API/Request.php:215]
#5 Piwik\API\Request->process(…) called at [/var/www/piwik.c6-berlin.com/core/ViewDataTable/Request.php:48]
#6 Piwik\ViewDataTable\Request->loadDataTableFromAPI(…) called at [/var/www/piwik.c6-berlin.com/core/Plugin/ViewDataTable.php:288]
#7 Piwik\Plugin\ViewDataTable->loadDataTableFromAPI(…) called at [/var/www/piwik.c6-berlin.com/core/Plugin/Visualization.php:166]
#8 Piwik\Plugin\Visualization->buildView(…) called at [/var/www/piwik.c6-berlin.com/core/Plugin/ViewDataTable.php:375]
#9 Piwik\Plugin\ViewDataTable->render(…) called at [/var/www/piwik.c6-berlin.com/plugins/BotTracker/Controller.php:76]
#10 Piwik\Plugins\BotTracker\Controller->getBotTrackerPie(…) called at [/var/www/piwik.c6-berlin.com/plugins/BotTracker/Controller.php:84]
#11 Piwik\Plugins\BotTracker\Controller->getBotTrackerPage(…) called at [:]
#12 call_user_func_array(…) called at [/var/www/piwik.c6-berlin.com/core/FrontController.php:500]
#13 Piwik\FrontController->doDispatch(…) called at [/var/www/piwik.c6-berlin.com/core/FrontController.php:85]
#14 Piwik\FrontController->dispatch(…) called at [/var/www/piwik.c6-berlin.com/core/dispatch.php:34]
#15 require_once(…) called at [/var/www/piwik.c6-berlin.com/index.php:47]


#2

What I did and technical spec.

I wanted to open the BOT Tracker under Dashboard - Visitor - Bot Tracker.

It was PHP 5.4, Apache 2.22, Wheezy with all relevant updates and MySQL 5.5.37-0+wheezy1 (Debian).
After I did now upgrade PHP 5.4 to PHP 5.5.12-1~dotdeb.1 (cli) (built: May 6 2014 03:56:10) it now works…


#3

Well, I’ve to correct myself, it doesn’t work…

To reproduce this, you simply need to take a longer time range over at least two years, e.g. 2013 - 2014.

Doing that reproduces the issue.


(Matthieu Aubry) #4

see my other reply 301 Moved Permanently