Von http auf https mit zweiter Installation (SSL-Zertifikat) kein Tracking


#1

Moin Moin zusammen! :smile:

Ich habe eine meiner Webseiten von http auf https mit einem SSL-Zertifikat von StartSSL versehen. Daf├╝r habe ich eine neue Installation von Piwik gemacht und diese als Subdomain der Domain mit SSL-Zertifikat angelegt.
(Hauptdomain mit StartSSL, Subdomain mit eigenem Zertifikat ├╝ber Plesk)

Bisher hat das Tracking keine Probleme gemacht, jetzt aber schon. Der neue Tracking-Code ist im Footer des WP-Themes eingebunden.
Ich habe es versucht, mein eigener Besuch auf der Seite wird getrackt, vom Handy nicht und von einem anderen PC auch nicht.

DoNotTrack habe ich in Piwik nicht ber├╝cksichtigt, auch das Tracking mit der Grafik wenn JavaScript nicht aktiviert wurde ist im Tracking-Code eingebunden.

Ich freue mich auf hilfreiche Tricks von euch, womit ich mein Piwik Tracking wieder komplett zum laufen bringe. :smile:


(Stefan Giehl) #2

Handelt es sich um ein vertrauensw├╝rdiges Zertifikat oder musstest du das auf deinem Rechner erst irgendwo akzeptieren? Wenn das Zertifikat von Piwik nicht vom Browser als sicher eingestuft wird findet kein Tracking statt.


#3

Ja, ich musste es akzeptieren.
Das Zertifikat habe ich ├╝ber meinen Server mit Plesk erstellt.

Ist es sonst ÔÇťganz einfachÔÇŁ m├Âglich, die Piwik Installation von der Subdomain auf die Hauptdomain in ein Unterverzeichnis umzuziehen? Wenn ja, wie?


(Stefan Giehl) #4

Das sollte gehen. Verschiebe Piwik und ├Ąndere den ÔÇťVertrauten Piwik HostnamenÔÇŁ in Piwik ab, dann sollte das Tracking wie zuvor funktionieren