Visits are not ignored correctly

I have noticed this problem as well, but only when I use Firefox. I use a Windows 7 system, and have all the latest versions of Firefox, Safari, Chrome, Internet Explorer, and Opera installed.

Firefox: 73.0.1 (64-bit)
Safari: 5.1.7 (7534.57.2)
Chrome: 80.0.3987.122 (Official Build) (64-bit)
Internet Explorer: 11.0.9600.19572
Opera: 66.0.3515.115

The problem occurs ONLY with Firefox. When I use any of the other browsers, my visits are ignored as expected when the “Ignore my visits” cookie is set. I UNDERSTAND fully that this option is browser-specific.

Hi @canajun2eh,

Can you check if maybe in firefox third-party-cookies are disabled (and the website is running on a different domain as the Matomo instance)?

Thanks for your suggestions. Third party cookies are enabled, and Matomo is running on the same server as the website. Matomo is in a different subdirectory from that of the web site (of course).

Please e-mail me directly at gkroll (at) keldine (dot) ca if you want to have the necessary credentials and information for accessing Matomo and also the web site.


I can take a look when I find some time in the next few days.

I’d prefer you to directly send me a mail to lukas @ the main domain of Matomo (as otherwise you won’t know if the mail is really by me or someone else reading this post :slight_smile: )