Visitors Real-Time log working, but "There is no data for this report" everywhere else


#1

I need help with my Piwik installation. My version is 2.0.3 - I just tried updating from an older version to see if my problem would be resolved, but I am still having problems.

In all the reports on the Dashboard I have “There is no data for this report” displaying. “Visits over time” shows 0 visits, too. I have tried setting the time to “today” to make sure I actually should be seeing data. I have also tried going over the FAQ at Troubleshooting - Analytics Platform - Matomo but nothing is helping so far.

“Visitors in Real-time” is actually displaying relevant data as visitors come in to my site. And the Visitors Log is working, but everything else tells me there is no data.

Piwik is installed on a Windows 2008 server with cron running (apparently successfully from the return value on the task) in the Task Scheduler every hour. Archiving triggered from the browser is disabled in settings, as instructed by the document helping me set-up cron.

PHP is version 5.3.4. I don’t see any errors in the php.ini log I set for error reporting.

I enabled the DBStats plugin in the Piwik Settings and under “Diagnostic - Database usage” and I see data in the Tracker Tables, Metric Tables, Metrics, and Other Tables. The Report Tables and Reports seem to have no row count.

Help?


(Matthieu Aubry) #2

See: Troubleshooting - Analytics Platform - Matomo


#3

Thank you for your reply - however, as I mentioned, I have worked through this FAQ already and have not been able to fix the problem. My results of working through the FAQ are listed in the original message. Anything else I can try?


#4

are you using the bulk tracker api? it sounds like aggregation isn’t happening correctly, try seeing if the the piwik_archive_* tables (assuming your prefix is default of ‘piwik_’) have any data, and try dropping those tables (which store the aggregated data) and re running your archive script

seeing raw log information can happen without aggregation happening correctly (as this information comes from just the raw logs) whereas aggregation allows everything else to show


(Matthieu Aubry) #5

Execute the script as in: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo -> it will process the data from the logs. Or maybe give you an error if something is not working?


#6

Having the same issue as well… brian47c, were you able to fix it?


#7

I am not using the bulk tracker API (that I know of…).

In the “Diagnostic - Database usage” tab under Settings, I see under the Report Tables that “piwik_archive_blob_*” tables are showing as below:

piwik_archive_blob_2014_02 16 K 16 K 16
piwik_archive_blob_2014_01 16 K 16 K -
piwik_archive_blob_2013_12 16 K 16 K -
piwik_archive_blob_2013_08 16 K 16 K -
piwik_archive_blob_2013_07 16 K 16 K -
piwik_archive_blob_2013_05 16 K 16 K 44
Total 96 K 96 K 60

How do I drop tables? After the tables are dropped, I assume I just let the cron that I setup in the task manager run again?


#8

I was able to figure out how to drop tables in MySQL and dropped all piwik_archive_* tables. I verified in Piwik under Settings - Diagnostic - Database Usage that they were gone.

I made sure a visitor from outside our network accessed our website, then I tried rerunning the cron archiving job in Windows Task Manager manually. The task ran and seemed to complete successfully.

Then I checked Piwik again. I still have the same situation. I can see active visitors on the site, but when I set the time frame to Today, it shows no visits and no data for any reports.

In Diagnostic - Database Usage, I see the Reports and Report Tables are both empty. Under Metric Tables I have data for piwik_archive_numeric_2014_01 and piwik_archive_numeric_2014_02.

???


(Matthieu Aubry) #9

did you setup: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo


#10

Yes, I did set up auto-archiving as indicated in the link you sent. It appears to be running successfully every hour.

The issue is still not resolved and I am still seeing “There is no data for this report” everywhere, despite being able to see data in “Visitors in Real-Time”.


(Matthieu Aubry) #11

So my guess is the automatic archive cron does not work as you expect. Maybe check that it’s setup ok?


(Neil Gee) #12

I also had this issue.

I had set the initial archive via cPanel cron but it didn’t work.

I then set it up via command line as described in the guide but check to use the right user - guide says www-data, but it depends on the set up of the server - the user may also be ‘nobody’ or in my case I have the server set up with suPHP and suEXEC so I used the domain username

Also cpanel guide doesn’t have http:// prefix whereas command line does - I used the prefix also - tested the command and now works as expected.


(Neil Gee) #13

also i adjusted the command to:


php /home/YOURNAME/public_html/piwik/misc/cron/archive.php --url=http://YOURYRL.com/piwik/ > /home/YOURNAME/piwik-archive-output.log

and disabled Shell Fork Bomb Protection in WHM