Visitor data not being collected in piwik_log_visit table


(earwax) #1

I installed Piwik 0.5.4 on a Red Hat 5 box at work. The technical requirements are met. No visitors are being logged in my piwik_log_visit table. The piwik.php is accessible, and the correct idsite is being passed. I am able to update tables via the Piwik web interface. I cannot think of any other reason why the database is not updating.

Any ideas?

I have a personal Piwik server. The personal one works great and I have no problems, and the set up is very similar to the one at work. It is hosted on a CentOS 5 Linux box. If I substitute my personal Piwik server tracking code into my work’s webpage, then everything works fine. I don’t want to mix and match my work and personal website tracking.


(earwax) #2

[quote=earwax @ Mar 2 2010, 09:17 PM]I installed Piwik 0.5.4 on a Red Hat 5 box at work. The technical requirements are met. No visitors are being logged in my piwik_log_visit table. The piwik.php is accessible, and the correct idsite is being passed. I am able to update tables via the Piwik web interface. I cannot think of any other reason why the database is not updating.

Any ideas?

I have a personal Piwik server. The personal one works great and I have no problems, and the set up is very similar to the one at work. It is hosted on a CentOS 5 Linux box. If I substitute my personal Piwik server tracking code into my work’s webpage, then everything works fine. I don’t want to mix and match my work and personal website tracking.[/quote]

I found out the problem. I looked in my /var/log/php file and found that there was a missing column missing, and that my database user did not have ALTER permissions. I had to reinstall Piwik and recreate the tables. After that, everything got fixed.

It was this Piwik ticket#: 478