Visited Pages Recorded as HTTPS or HTTP at Random


#1

The problem I am experiencing is that the URL of visited pages in visitor stats show up as either HTTPS or HTTP while the whole site is in https-only.

The behavior doesn’t change for a single page, but rather each page seems to behave differently. But I cannot find any significant difference between the pages.

The site is on WordPress and was not using an SSL certificate in the past. However, even pages that were never HTTP might be showing up in HTTP.

  • I’ve checked the site with many tools to verify SSL integrity
  • According to Google webmasters tools everything is fine
  • Canonical URL of all pages is set to HTTPS
  • All HTTP pages forward to HTTPS
  • In Settings --> Websites --> Manage website URL is set to HTTPS
  • I’ve added the “force_ssl = 1” setting to configurations

Any ideas on how to fix this would be much appreciated!

The site is at www.webhostwhat.com

Thanks & regards,
Tim


(Lukas Winkler) #2

Hi,

I think this is a known issue. If a website has been tracked as http in the past it will still be shown as http even though it got tracked via https.

You should be able to find the corresponding issue with more details on github.


#3

Thank you for the reply.

As far as I understood, I should change the url_prefix action types for all URL entries in the piwik_log_action table. However, I have no idea if this is possible or how I could achieve that?

url_prefix: if the name is a URL this refers to the prefix of the URL. The prefix is removed from actual URLs so the protocol and www. parts of a URL are ignored during analysis. Can be the following values:
0: 'http://'
1: 'http://www.'
2: 'https://'
3: ‘https://www.’

I’ve confirmed, that url_prefix is set to “1” for those pages that are showing up as HTTP in the stats.


#4

If anyone ever reads this, the only way I could solve this was to re-install Matomo from the very beginning. Even deleting all the stats had no effect.