Upgraded to 2.4.0 - Can no longer access Settings


#1

Since Upgrading to 2.4.0 this morning I can no longer access Settings in Piwik.

When I click the dropdown, ‘Email Reports’, ‘Widgets’, ‘API’, and ‘Help’ all work fine. However when I click ‘Settings’ it hangs on http://www.[mydomain].com/piwik/index.php?module=CoreAdminHome for a couple seconds and then redirects to http://www.[mydomain].com/piwik/index.php?module=UsersManager&action=userSettings&idSite=1&period=day&date=yesterday and just gives the errors I attached (chrome and firefox)

Also, If I activate ‘Zen Mode’ when I type something in like ‘Settings’ or ‘Referrers’ it correctly shows the options, but when I click them nothing happens.

Additionally, all of the reporting seems to still work fine, and I get no errors in my PHP log when this is trying to load.


(thoro) #2

…same here.


(Matthieu Aubry) #3

Could you please email thomas@piwik with your Piwik URL, login, password, bug description, and link to this forum post? He will assist with troubleshooting this issue. thanks


(thoro) #4

I think I’m not allowed to give you a login to our Piwik system as it is a corporate installation.

I took a look at the error log of the apache2 and each time I try to enter Piwik Setup it shows two new segmentation faults.

Aaron, did you find a solution with Thomas? I’d be really interested… :slight_smile:

Cheers

Thorsten


#5

I checked my apache error_logs and found the same thing.

When I click Settings I get this:

[Thu Jul 03 09:17:01 2014] [notice] child pid 27410 exit signal Segmentation fault (11)
[Thu Jul 03 09:17:02 2014] [notice] child pid 27401 exit signal Segmentation fault (11)
[Thu Jul 03 09:17:02 2014] [notice] child pid 27402 exit signal Segmentation fault (11)
[Thu Jul 03 09:17:03 2014] [notice] child pid 26441 exit signal Segmentation fault (11)

I have not emailed anything, and it would not matter anyway as this installation of piwik is only available if connecting from our local network. It is not replicated to the public server.

My guess is some kind of infinite recursion??


#6

Same issue here…


(thoro) #7

I put this into the issue tracker:


(thoro) #8


#9

Same here! Settings button lost. :frowning:

Dashboard | All Websites | | Logout |


#10

Same, can not access the settingspage :X

error shows:
Fatal error: Class ‘Piwik_Plugin’ not found in /home/latap/domains/mydomain.com/public_html/bin/piwik/plugins/ExampleUI/ExampleUI.php on line 27


#11

I’m having this problem now with 4 different domains and receive emails from my clients.
It’s getting really serious now and I would love to see a solution on how to solve this.

Should I completely copy a new version over the old one on the server, partialy renew files, what can I do?

Thanks a lot for a solution!
JohN


#12

How nice,

In the new version there is no /plugins/ExampleUI/ExampleUI.php file at all.
That caused the error and blocking access to the settingspage

So deleting that file (/plugins/ExampleUI/ExampleUI.php) solved the issue.

Should be removed by the upgrade process I think ?


#13

I have a clean install of Piwik 2.4.0 and I can’t enter admin/settingspage.

My apache log shows: child pid ??? exit signal Segmentation fault (11)

When I have created /plugins/ExampleUI/ExampleUI.php with, a empty class, the error apear too.

The problem is not a simple one.

I made another test:

  1. Piwik 2.3.0 clean install - settingspage works
  2. Piwik 2.4.0 auto update - settingspage does not work

(Matthieu Aubry) #14

Thanks for the report!

What apache version do you use?

What PHP version?


(thoro) #15

We are running Apache 2.2.20 with PHP 5.3.6 and APC 3.1.7.

Apache Version: Apache/2.2.20 (Ubuntu)
Apache API Version: 20051115
PHP Version: 5.3.6-13ubuntu3.10
APC Version: 3.1.7

Cheers

Thorsten


#16

Same problem on all Piwik installations we maintain. All have been updated to 2.4 recently, and all show the same bug: the link to the settings page ist gone. See attachment.

May be a hint: we use custom names for the admin logins, not the standard “admin”.


#17

We’re running 2.4.0 & settings appear ok & work without any problem. I’m an admin user but not named ‘admin’.


#18

not fixed in 2.4.1. No Settings and No API Button. :frowning:


#19

Update: Access to the settings is still possible if I directly go to the correct URL with /index.php?module=CoreAdminHome

But this is only a Workaround… :frowning:


#20

Last couple posts are users that are confused that Settings is now in the dropdown on the top, which has nothing to do with this issue.

Still does not work on 2.4.1 I was not expecting it to though as this was not listed as a fixed issue.

I found an interesting thing though, I recently installed piwik on a second server, which uses the same url, and uses the same database (one server, users outside our local network access with visiting www.[ourdomain].com, and another is used for users on the local network) the settings work on the other (public) server, but still not the local server. I am wondering if for whatever reason when settings is click some outside resource is being requested that is being blocked or something weird like that? I do not have the time to dig into the piwik codebase.

The servers are set up identically, replicate the exact same files for piwik, and share the same database.