Upgraded to 2.14: iframe widgets permission issue


#1

I embed Piwik to my website using iframe widgets, here is one of the URL that works before 2.14:

https://<my_server.com>/index.php?action=iframe&actionToWidgetize=getCountry&disableLink=1&idSite=71&language=en&module=Widgetize&moduleToWidgetize=UserCountry&token_auth=<my_token>&widget=1&period=range&date=2015-06-09,2015-07-08

but after upgrade to 2.14, it shows:
Error: You can’t access this resource as it requires an ‘view’ access for the website id = 71.

I login admin page to double check:
https://<my_server.com>/index.php?module=UsersManager&action=index&idSite=71&period=day&date=yesterday
[attachment 2334 piwik.png]

the token is correct.

is this a bug?


#2

Same issue here.

I just upgraded to 2.14 and it works as long as I am logged in as admin in another window. When I log out, same error “Error: You can’t access this resource as it requires an ‘view’ access for the website id = ID”.

The token_auth is correct but doesn’t seem to come through. In the Users Management table the LAST SEEN column shows a time lap from just before the upgrade.


(Matthieu Aubry) #3

Hello,

This bug was fixed in 2.14.1-b1 - it will be released in coming 2 weeks but you can already update to enjoy this fix: I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo


#4

Thanks Matt,

The upgrade to 2.14.1-b1 fixed my problem.

Regards,
Wilco


#5

most of the widget fixed in 2.14.1-b1, however, some widgets such as “browser types”, it shows an error page:

The plugin UserSettings is not enabled. You can activate the plugin on Settings > Plugins page in Piwik.
https://<my_domain>/index.php?action=iframe&actionToWidgetize=getMobileVsDesktop&disableLink=1&idSite=71&language=zh-cn&module=Widgetize&moduleToWidgetize=UserSettings&token_auth=<my_token>&widget=1&period=range&date=2015-06-13,2015-07-12

However when I go into that setting page, can’t find any setting for that…


#6

Hi ledowong,

It looks your permission issue has been solved, but you deal with another issue. Some moduleToWidgetize / actionToWidgetize have been altered several versions ago. UserSettings is not available anymore. You can check the right combi’s in Widgetize reports.

Regards,
Wilco