Upgrade Matomo 5 RC4 to Matomo 5 RC7?

I installed Matomo 5 RC 4, now I would like to upgrade to RC 7. I’ve read this article: https://matomo.org/faq/on-premise/update-matomo/ regarding manual upgrade (since when I click Check for Updates - I get message I am using the most resent version …). Can I configure this check to pick up RC-versions?

Here is my main main question. I’ve

  1. set Matomo in maintenance_mode
  2. Via wget I downloaded Matomo 5 RC7.zip into my “root” folder where I have Matomo 5 RC4 installed
  3. Unzipped the archive into “root/Matomo”
  4. Deleted zip-archive Matomo 5 RC7.zip
  5. I’ve checked for any obsolete files with “./console diagnostics:unexpected-files”
  6. I’ve deleted obsolete files with “./console diagnostics:unexpected-files --delete”
  7. When I enter my domain root, I get still get “Matomo is undergoing maintenance”

I don’t get any upgrade script or anything. I guess I am doing something wrong here? Is step 3) supposed to replace all old files, now I’ve copied them into a subfolder called “root/Matomo”?

Hi @Fred_Ahlen
Very strange.
Did you try to manually update the database (command also provided in the document you linked in your first post)?

$ ./path/to/matomo/console core:update

Did you try to clean-up caches (server-side and client side)?
→ Reboot server and press Ctrl + F5 keys in the browser…

Thank you for info. Maybe I read the guide for manual update, a bit wrong (or interpreted it wrong). I add more info to enlighten the community. It was probably crap-behind-the-keyboard … :slight_smile:

I unzipped the the Matomo 5 RC7.zip into “www-root/matomo” and I assume it should have been unzipped into “www-root” instead.This way the new files never came into play. I might have read article: [https://matomo.org/faq/on-premise/update-matomo/] too fast, but I ended up copy the files from the Matomo folder into the “www-root” with “\cp -rfa --no-preserv=all public_html/matomo/* public_html/”.

For me it was important to copy the files recursively and to also preserve the owner and permissions on destination folders and files since I secured the files/folders according to your best practice.

After this I turned off “Maintenance mode” and entered the www-root from a browser. Then the upgrade script ran OK, with an upgrade of the database as well. Now admin part of Matomo says I run Matomo RC 7.

1 Like

Hi @Fred_Ahlen
The everything is running well now, isn’t it?

Yes everything is running well now. I managed to manually upgrade to version 5 RC7. Thank you for the advice about manually upgrade the database, I will keep that in mind for next upgrade.

1 Like