Upgrade failed?

An error occurred
To run Matomo you need at least PHP version 7.2.5

Unfortunately it seems your webserver is using PHP version 7.1.33.

Please try to update your PHP version, Matomo is really worth it! Nowadays most web hosts support PHP 7.2.5.

Before the upgrade, my version was 3.14.
However, my hosting provider cannot upgrade PHP for me, so how can I return to 3.14.0?

Thank you!


Are you referring to the Wordpress plugin (https://wordpress.org/plugins/matomo/) or the standalone Matomo instance?

Thank you


You can go back by replacing all files with the ones from the version you want.
You can download any version from https://builds.matomo.org/

If you already applied the database changes, you need to follow https://matomo.org/faq/how-to/how-do-i-downgrade-from-matomo-4-to-matomo-3/ to revert them.

That said PHP 7.2 came out in 2017, so I’d really recommend you (or your hosting provider) to switch to a never version.

Thank you!
I will try it right away.