Upgrade Error


(J Stern) #1

Reporting an error in upgrading to version 1.4

There is an error. Please report the message and full backtrace in the Piwik forums.

Warning: unlink(J:\dev\trunk\public\piwik/tmp/latest/latest.zip) [function.unlink]: Permission denied in J:\dev\trunk\public\piwik\plugins\CoreUpdater\Controller.php on line 110

Backtrace -->
#0 Piwik_ErrorHandler(2, unlink(J:\dev\trunk\public\piwik/tmp/latest/latest.zip) [function.unlink]: Permission denied, J:\dev\trunk\public\piwik\plugins\CoreUpdater\Controller.php, 110, Array ([archive] => Piwik_Unzip_ZipArchive Object ([] => ZipArchive Object ([status] => 0,[statusSys] => 0,[numFiles] => 2314,[filename] => J:\dev\trunk\public\piwik\tmp\latest\latest.zip,[comment] => ),[filename] => J:\dev\trunk\public\piwik/tmp/latest/latest.zip),[pathExtracted] => J:\dev\trunk\public\piwik/tmp/latest/,[archive_files] => Array ([0] => Array ([filename] => J:\dev\trunk\public\piwik/tmp/latest/piwik/,[stored_filename] => piwik/,[size] => 0,[compressed_size] => 0,[mtime] => 1304156864,[index] => 0,[crc] => 0),[1] => Array ([filename] => J:\dev\trunk\public\piwik/tmp/latest/piwik/tmp/,[stored_filename] => piwik/tmp/,[size] => 0,[compressed_size] => 0,[mtime] => 1304156850,[index] => 1,[crc] => 0),[2] => Array ([filename] => J:\dev\trunk\public\piwik/tmp/late…#1 unlink(J:\dev\trunk\public\piwik/tmp/latest/latest.zip) called at [J:\dev\trunk\public\piwik\plugins\CoreUpdater\Controller.php:110]#2 Piwik_CoreUpdater_Controller->oneClick_Unpack() called at [J:\dev\trunk\public\piwik\plugins\CoreUpdater\Controller.php:62]#3 Piwik_CoreUpdater_Controller->oneClickUpdate()#4 call_user_func_array(Array ([0] => Piwik_CoreUpdater_Controller Object ([] => ,[] => Array (),[] => Array (),[] => Array (),[] => CoreUpdater,[] => ,[] => ,[] => 0,[] => Piwik_Site Object ([] => 0),[pathPiwikZip] => J:\dev\trunk\public\piwik/tmp/latest/latest.zip),[1] => oneClickUpdate), Array ()) called at [J:\dev\trunk\public\piwik\core\FrontController.php:125]#5 Piwik_FrontController->dispatch() called at [J:\dev\trunk\public\piwik\index.php:60]


(vipsoft) #2

What are the permissions on tmp/latest/latest.zip?


(J Stern) #3

It would be default windows settings on this machine.

Looks like everyone but ‘USERS’ has full control, users only has ‘read & execute’ + ‘read’, which might be the problem.

The installation seems to have worked even with receiving this error. Do you suggest running it again or how should I go about continuing from here?


(J Stern) #4

I went ahead and continued to the database upgrade, but killed our DB servers twice.

Tried doing the DB upgrade using the link from the installation, after about 5 minutes I was seeing that our sites would die and logs filled up with “PHP Fatal error: Uncaught exception ‘PDOException’ with message ‘SQLSTATE[08004] [1040] Too many connections’ …” errors.

I tried again running the the queries manually and same thing happened once I reached query #9

“ALTER TABLE piwik_log_visit ADD INDEX index_idsite_datetime_config (idsite, visit_last_action_time, config_id) ;”

Not sure if this is related to a dev bug that has been closed here #1760.

Not sure what im going to try next, my my.cnf has max_connections commented out, so this should be unlimited as far as I understand it?