Upgrade and/or new installation same error


#1

hi , (…want help)

i have try upgrade my exist piwik and get error ,…try a new fresh installation, also get error (the same) :

Notice: Undefined index: idSites in /var/www/vhosts/mysite.com/mysite-piwik/plugins/ImageGraph/ImageGraph.php on line 42

Backtrace -->
#0 Piwik_ErrorHandler(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/plugins/ImageGraph/ImageGraph.php:42]#1 Piwik_ImageGraph->getReportMetadata(…) called at [:]#2 call_user_func_array(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/libs/Event/Dispatcher.php:284]#3 Event_Dispatcher->postNotification(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/core/PluginsManager.php:609]#4 Piwik_PostEvent(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/plugins/API/API.php:408]#5 Piwik_API_API->getReportMetadata(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/plugins/API/API.php:347]#6 Piwik_API_API->getMetadata(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/core/ViewDataTable.php:1021]#7 Piwik_ViewDataTable->loadDocumentation(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/core/ViewDataTable.php:1011]#8 Piwik_ViewDataTable->getReportDocumentation(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/core/ViewDataTable/GenerateGraphHTML.php:124]#9 Piwik_ViewDataTable_GenerateGraphHTML->buildView(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/core/ViewDataTable/GenerateGraphHTML.php:92]#10 Piwik_ViewDataTable_GenerateGraphHTML->main(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/core/Controller.php:146]#11 Piwik_Controller->renderView(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/plugins/Goals/Controller.php:339]#12 Piwik_Goals_Controller->getEvolutionGraph(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/plugins/Goals/Controller.php:191]#13 Piwik_Goals_Controller->getGoalReportView(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/plugins/Goals/Controller.php:66]#14 Piwik_Goals_Controller->ecommerceReport(…) called at [:]#15 call_user_func_array(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/core/FrontController.php:136]#16 Piwik_FrontController->dispatch(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/core/FrontController.php:156]#17 Piwik_FrontController->fetchDispatch(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/plugins/CoreHome/Controller.php:50]#18 Piwik_CoreHome_Controller->showInContext(…) called at [:]#19 call_user_func_array(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/core/FrontController.php:136]#20 Piwik_FrontController->dispatch(…) called at [/var/www/vhosts/mysite.com/mysite-piwik/index.php:53]


(Matthieu Aubry) #2

Make sure all files are uploaded correctly, probably some files were not uploaded correctly during upgrade.


#3

…i’m sorry but this not is the first installation and/or upgrade of release , all release (before 1.6) update and/or installation work fine with same procedure, …are change any (not mentioned) for install ?

…also my piwik installation start and running only some windows at dashboard no work and get the error “pasted”.