Updating matomo installation without loosing data

escalated

#1

Hi there,

according to How do I upgrade a large Piwik instance without losing any tracking data? FAQ - Analytics Platform - Matomo there are two ways to update a matomo installation without loosing data.
I tested option 2 and set my Matomo installation and tracker into mainenance according to faq (How do I momentarily disable Piwik User Interface and/or Piwik visitor Tracking? FAQ - Analytics Platform - Matomo)
However, if I set the tacker into mainenance (“record_statistics = 0”) the requests are not saved (when using the http tracker api).
Using only “maintenance_mode = 1” it does work like expected.
What is the recommended way to do that? Is the FAQ wrong and you should not set “record_statistics = 0”?


(Matthieu Aubry) #2

Hi there,

Thanks for the feedback, in Option 2 there was a step missing:

I’ve updated the faq. Could you maybe try again option 2 and check if this works for you now?


#3

Thank you for the update.
When enabling only the maintenance option, the server does not lose any tracking data and the maintenance window is shown when accessing the web ui.
While the maintenance option is enabled all requests in the redis queue are processed when the limit is reached (“Number of requests that are processed in one batch”), is this the expected behaviour? I thought the redis queue might fill with requests and the requests are only processed when the maintenance option is set to 0 again.


(Matthieu Aubry) #4

Thanks for the feedback. There was still another step missing which has been added to FAQ:

  1. Disable the setting “Process during tracking request”. Check you have not setup a cronjob running queuedtracking:process. (We want to make sure the requests in the queue are not processed).

Now hopefully it works as expected?


#5

Thank you for the update. It seems like everything is working now.